summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2024-02-14 22:30:08 +0100
committerNarrat2024-02-14 22:30:08 +0100
commitfddae42777a7fd7724eedba9fe9de39d99dbb171 (patch)
tree64079bb5d34a1fd6492b44791532df7c19d0ac55
parentb78d5914426f794b17b6018d2b58c391255b1a40 (diff)
downloadaur-fddae42777a7fd7724eedba9fe9de39d99dbb171.tar.gz
monkey: update to 1.7.3
* change upstream url (URL not valid) * therefore change download url * adjust build instructions (those are a mess...) Build fails currently, because the upstream make files are a mess. Upstream is aware of the problem, but no fix as of now..
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb5a651a6751..399f3816dd2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = monkey
pkgdesc = Lightweight and powerful web server
- pkgver = 1.6.9
+ pkgver = 1.7.3
pkgrel = 1
- url = http://monkey-project.com/
+ url = https://github.com/monkey/monkey
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
depends = mbedtls
options = !emptydirs
- source = http://monkey-project.com/releases/1.6/monkey-1.6.9.tar.gz
- sha1sums = 70895f0d82418ad15fd84b15ad845537e26a39ac
+ source = monkey-1.7.3.tar.gz::https://github.com/monkey/monkey/archive/refs/tags/v1.7.3.tar.gz
+ sha1sums = 3ffb76235aec734188fbc41f97ef661cf05cf9ab
pkgname = monkey
-
diff --git a/PKGBUILD b/PKGBUILD
index 01f05162b1de..c89370601ad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
pkgname=monkey
-pkgver=1.6.9
+pkgver=1.7.3
pkgrel=1
pkgdesc='Lightweight and powerful web server'
-url='http://monkey-project.com/'
+url='https://github.com/monkey/monkey'
arch=('i686' 'x86_64')
license=('Apache')
depends=('mbedtls')
makedepends=('cmake')
-source=("http://monkey-project.com/releases/${pkgver%.*}/monkey-${pkgver}.tar.gz")
-sha1sums=('70895f0d82418ad15fd84b15ad845537e26a39ac')
-
options=('!emptydirs')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha1sums=('3ffb76235aec734188fbc41f97ef661cf05cf9ab')
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir build
./configure \
--malloc-libc \
--mbedtls-shared \
@@ -28,10 +29,11 @@ build() {
--default-port=80 \
--default-user=http \
+ make CMAKE_COMMAND="/usr/bin/cmake" RM="/usr/bin/cmake" CMAKE_SOURCE_DIR="." CMAKE_BINARY_DIR="." DESTDIR="${pkgdir}"
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make CMAKE_COMMAND="/usr/bin/cmake" RM="/usr/bin/cmake" CMAKE_SOURCE_DIR="." CMAKE_BINARY_DIR="." DESTDIR="${pkgdir}" install
rm -fr "${pkgdir}"/srv/http
}