summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-08-26 20:37:20 +0300
committerDet2015-08-26 20:37:20 +0300
commitfde3de98a62e9ee43c32f214ee5982c43c2e5b6e (patch)
treed46b8db22441fb5f77c827cb43c24cba6c676fd7
parentf22de421e5335e6a3e944a4d45b86c30b4ad1e4c (diff)
downloadaur-fde3de98a62e9ee43c32f214ee5982c43c2e5b6e.tar.gz
Support ~/.config/chrome-dev-flags.conf
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--google-chrome-dev.install2
-rw-r--r--google-chrome-unstable9
4 files changed, 19 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8836cef4c366..54b4b668158c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,7 +32,9 @@ pkgbase = google-chrome-dev
provides = pepper-flash
options = !emptydirs
options = !strip
+ source = google-chrome-unstable
source = eula_text.html
+ md5sums = 00541a2eaedf40c2217f17f9345aaa5c
md5sums = b7e752f549b215ac77f284b6486794b6
source_i686 = google-chrome-unstable_46.0.2490.4_i386.deb::https://dl.google.com/linux/direct/google-chrome-unstable_current_i386.deb
md5sums_i686 = 3abe6d00eadda73e9a839b721edc5b23
diff --git a/PKGBUILD b/PKGBUILD
index 5751d1ee1765..1ad964d076b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,12 @@ provides=('google-chrome' 'pepper-flash')
options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=unstable
-source=('eula_text.html')
+source=('google-chrome-unstable'
+ 'eula_text.html')
source_i686=("google-chrome-${_channel}_${pkgver}_i386.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_i386.deb")
source_x86_64=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb")
-md5sums=('b7e752f549b215ac77f284b6486794b6')
+md5sums=('00541a2eaedf40c2217f17f9345aaa5c'
+ 'b7e752f549b215ac77f284b6486794b6')
md5sums_i686=('3abe6d00eadda73e9a839b721edc5b23')
md5sums_x86_64=('4cbe8b5b5fd11d1ca17c3fa6522c24aa')
@@ -36,6 +38,9 @@ package() {
bsdtar -xf data.tar.xz -C "$pkgdir/"
msg2 "Moving stuff in place..."
+ # Launcher
+ install -m755 google-chrome-unstable "$pkgdir"/usr/bin/
+
# Icons
for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "$pkgdir"/opt/google/chrome-$_channel/product_logo_${i/x*}.png \
diff --git a/google-chrome-dev.install b/google-chrome-dev.install
index 2dbe1662b766..653fac120109 100644
--- a/google-chrome-dev.install
+++ b/google-chrome-dev.install
@@ -22,7 +22,7 @@ _update() {
post_install() {
_update
-
+ note "Custom flags should be put directly in: ~/.config/chrome-dev-flags.conf"
note "The launcher is called: 'google-chrome-unstable'"
}
diff --git a/google-chrome-unstable b/google-chrome-unstable
new file mode 100644
index 000000000000..22129b3bbddc
--- /dev/null
+++ b/google-chrome-unstable
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# Allow users to override command-line options
+if [[ -f ~/.config/chrome-dev-flags.conf ]]; then
+ CHROME_USER_FLAGS="$(cat ~/.config/chrome-dev-flags.conf)"
+fi
+
+# Launch
+exec /opt/google/chrome-unstable/google-chrome-unstable $CHROME_USER_FLAGS $@ \ No newline at end of file