summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2023-07-13 08:25:31 +0200
committerFrederic Bezies2023-07-13 08:25:31 +0200
commitfdfd3cb58aa8f19934b5ed7c0cc9101f62f0fc98 (patch)
tree4cf89373181f41bd288a0b52f3e410f69befcb66
parent9285194a25ef0c8cb0de1bb21489007b58141bd9 (diff)
downloadaur-fdfd3cb58aa8f19934b5ed7c0cc9101f62f0fc98.tar.gz
working around broken git tag upstream
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 469a6134ebed..197d6a49dd38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = zesarux-git
pkgdesc = A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support. Development version.
- pkgver = 10.3.r173.gef5e6d1
+ pkgver = r2727.f4cf7ce
pkgrel = 1
+ epoch = 1
url = https://github.com/chernandezba/zesarux
install = zesarux.install
arch = i686
@@ -15,7 +16,7 @@ pkgbase = zesarux-git
optdepends = openssl: for enable SSL functions
optdepends = sdl: for support sdl video and audio output
conflicts = zesarux
- source = zesarux-code::git+https://github.com/chernandezba/zesarux.git#commit=ef5e6d1
+ source = zesarux-code::git+https://github.com/chernandezba/zesarux.git
source = zesarux.desktop
source = zesarux.png
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2107c080c213..7dd926831872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,10 @@
# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=zesarux-git
-pkgver=10.3.r173.gef5e6d1
+pkgver=r2727.f4cf7ce
_ver=10.10
pkgrel=1
+epoch=1
pkgdesc="A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support. Development version."
arch=('i686' 'x86_64')
url="https://github.com/chernandezba/zesarux"
@@ -14,7 +15,7 @@ depends=('libxxf86vm' 'aalib' 'libcaca' 'alsa-lib')
optdepends=('libpulse: for support Pulseaudio'
'openssl: for enable SSL functions'
'sdl: for support sdl video and audio output')
-source=('zesarux-code::git+https://github.com/chernandezba/zesarux.git#commit=ef5e6d1'
+source=('zesarux-code::git+https://github.com/chernandezba/zesarux.git'
zesarux.desktop
zesarux.png)
install="zesarux.install"
@@ -24,7 +25,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/zesarux-code"
- git describe --long --tags | sed 's/^ZEsarUX-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {