summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorganamilo2018-05-25 03:04:06 +0100
committermorganamilo2018-05-25 03:04:06 +0100
commitfe294fef8ee85c18715a787b7e95c0608b9de754 (patch)
treec915788a386d752ef2a4d696ca0261af68a82a50
parent6631ae2495d94b76a804d85497ad700895703d5e (diff)
downloadaur-fe294fef8ee85c18715a787b7e95c0608b9de754.tar.gz
New PKGBUILD based on extra/mpd
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD100
-rw-r--r--conf (renamed from mpd.conf)1
-rw-r--r--mpd-system.socket10
-rw-r--r--mpd-user.socket9
-rw-r--r--mpd.install11
-rw-r--r--mpd.service8
-rw-r--r--mpd.tmpfile1
-rw-r--r--sysusers.d2
-rw-r--r--tmpfiles.d3
10 files changed, 71 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62c094d74d42..b5201815b272 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = mpd-git
pkgdesc = Flexible, powerful, server-side application for playing music
- pkgver = 0.19.9.r485.gcd1148c
+ pkgver = 0.20.20.r935.g66a1e8b73
pkgrel = 1
- url = http://www.musicpd.org/
- install = mpd.install
- arch = i686
+ url = https://www.musicpd.org/
arch = x86_64
license = GPL
makedepends = boost
makedepends = doxygen
- makedepends = git
depends = libao
depends = ffmpeg
depends = libmodplug
@@ -18,8 +15,6 @@ pkgbase = mpd-git
depends = libmad
depends = curl
depends = faad2
- depends = boost-libs
- depends = libupnp
depends = sqlite
depends = jack
depends = libmms
@@ -28,23 +23,26 @@ pkgbase = mpd-git
depends = libid3tag
depends = yajl
depends = libmpdclient
- depends = opus
+ depends = icu
+ depends = libupnp
+ depends = libnfs
+ depends = libsamplerate
depends = libsoxr
+ depends = smbclient
+ depends = libgme
+ depends = zziplib
+ depends = libsystemd
provides = mpd
conflicts = mpd
backup = etc/mpd.conf
- source = mpd-git::git://git.musicpd.org/master/mpd.git
- source = mpd.conf
- source = mpd.tmpfile
- source = mpd.service
- source = mpd-system.socket
- source = mpd-user.socket
+ source = mpd::git+https://github.com/MusicPlayerDaemon/MPD
+ source = tmpfiles.d
+ source = sysusers.d
+ source = conf
sha256sums = SKIP
- sha256sums = 1dafb23f2da8df4600de0be51677201f63f745bd572f7a6fcd8fa7659ac691ea
- sha256sums = c1683ba35774c85e16c70e89f7e2ed1c09619512b1a273daabbd5e34d40439bd
- sha256sums = ecb4caedf02dacdb9b71040794145d7547d7ee8349eaea200cbddab85d67ee95
- sha256sums = a05936116d59d442a5f94858f30e759389719ed2ac6dbef25a512d952a156658
- sha256sums = a650e25f9e4490e6dc7172ff95bfb7a1df28175d365741c3d98af3849c4b5428
+ sha256sums = 2faa85c12449a5b3ca422ff1c1fa06d057c7e262a74bfa6298c914a92d6f2e7a
+ sha256sums = 0b74c6e5db08daab3091dc15a6b0c75210ba2f9e98fa074f6cfd605a461056b6
+ sha256sums = f40f68205834ca53cea3372e930bfe6c2f9ecc9df3b1605df2fec63a658b2e03
pkgname = mpd-git
diff --git a/PKGBUILD b/PKGBUILD
index 3ac5c8ecafc2..bd0084d41cad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
-# Maintainer: sudokode <sudokode@gmail.com>
+# Maintainer: e5ten
+# Maintainer: anna <morganamilo@gmail.com>
+# Contributor: sudokode <sudokode@gmail.com>
# Contributor: graysky <graysky AT archlinux DOT us>
# Contributor: Slash <demodevil5[at]yahoo[dot]com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
@@ -7,71 +9,67 @@
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
# Contributor: Ben <ben@benmazer.net>
+
pkgname=mpd-git
-pkgver=0.19.9.r485.gcd1148c
+_pkgname=mpd
+pkgver=0.20.20.r935.g66a1e8b73
pkgrel=1
pkgdesc='Flexible, powerful, server-side application for playing music'
-url='http://www.musicpd.org/'
+url='https://www.musicpd.org/'
license=('GPL')
-arch=('i686' 'x86_64')
-depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl' 'faad2' 'boost-libs' 'libupnp'
- 'sqlite' 'jack' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl' 'libmpdclient' 'opus' 'libsoxr')
-makedepends=('boost' 'doxygen' 'git')
+arch=('x86_64')
+depends=('libao' 'ffmpeg' 'libmodplug' 'audiofile' 'libshout' 'libmad' 'curl'
+ 'faad2' 'sqlite' 'jack' 'libmms' 'wavpack' 'avahi' 'libid3tag' 'yajl'
+ 'libmpdclient' 'icu' 'libupnp' 'libnfs' 'libsamplerate' 'libsoxr'
+ 'smbclient' 'libgme' 'zziplib' 'libsystemd')
+makedepends=('boost' 'doxygen')
provides=('mpd')
conflicts=('mpd')
-source=("$pkgname::git://git.musicpd.org/master/mpd.git"
- 'mpd.conf' 'mpd.tmpfile' 'mpd.service' 'mpd-system.socket' 'mpd-user.socket')
+source=("$_pkgname::git+https://github.com/MusicPlayerDaemon/MPD"
+ 'tmpfiles.d'
+ 'sysusers.d'
+ 'conf')
sha256sums=('SKIP'
- '1dafb23f2da8df4600de0be51677201f63f745bd572f7a6fcd8fa7659ac691ea'
- 'c1683ba35774c85e16c70e89f7e2ed1c09619512b1a273daabbd5e34d40439bd'
- 'ecb4caedf02dacdb9b71040794145d7547d7ee8349eaea200cbddab85d67ee95'
- 'a05936116d59d442a5f94858f30e759389719ed2ac6dbef25a512d952a156658'
- 'a650e25f9e4490e6dc7172ff95bfb7a1df28175d365741c3d98af3849c4b5428')
-backup=('etc/mpd.conf')
-install=mpd.install
-
-pkgver() {
- cd $pkgname
+ '2faa85c12449a5b3ca422ff1c1fa06d057c7e262a74bfa6298c914a92d6f2e7a'
+ '0b74c6e5db08daab3091dc15a6b0c75210ba2f9e98fa074f6cfd605a461056b6'
+ 'f40f68205834ca53cea3372e930bfe6c2f9ecc9df3b1605df2fec63a658b2e03')
- git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
-}
+backup=('etc/mpd.conf')
build() {
- cd $pkgname
+ cd "${_pkgname}"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-jack \
+ --enable-libmpdclient \
+ --enable-pipe-output \
+ --enable-pulse \
+ --enable-soundcloud \
+ --enable-zzip \
+ --disable-sidplay \
+ --enable-systemd-daemon \
+ --with-systemduserunitdir=/usr/lib/systemd/user \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system \
- ./autogen.sh
-
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-jack \
- --enable-soundcloud \
- --enable-pipe-output \
- --enable-pulse \
- --disable-sidplay \
- --with-systemdsystemunitdir=/usr/lib/systemd/system \
- --enable-opus \
- --disable-lsr \
- --enable-soxr \
- --disable-aac
-
- make
+ make
}
package() {
- cd $pkgname
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 ../conf "${pkgdir}"/etc/mpd.conf
+ install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/mpd.conf
+ install -Dm644 ../sysusers.d "${pkgdir}"/usr/lib/sysusers.d/mpd.conf
- make DESTDIR="$pkgdir" install
+ sed '/\[Service\]/a User=mpd' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+ sed '/WantedBy=/c WantedBy=default.target' -i "${pkgdir}"/usr/lib/systemd/system/mpd.service
+}
- cd ..
- install -d -g 45 -o 45 "$pkgdir"/var/lib/mpd
- install -d -g 45 -o 45 "$pkgdir"/var/lib/mpd/playlists
- install -Dm644 mpd.conf "$pkgdir"/etc/mpd.conf
- install -Dm644 mpd.tmpfile "$pkgdir"/usr/lib/tmpfiles.d/mpd.conf
- install -Dm644 mpd.service "$pkgdir"/usr/lib/systemd/user/mpd.service
- install -Dm644 mpd-system.socket "$pkgdir"/usr/lib/systemd/system/mpd.socket
- install -Dm644 mpd-user.socket "$pkgdir"/usr/lib/systemd/user/mpd.socket
-}
+pkgver() {
+ cd "${_pkgname}"
-# vim:set ts=2 sw=2 et:
+ git describe --long | sed 's/^v//; s/\([^-]*-g\)/r\1/; s/-/./g'
+}
diff --git a/mpd.conf b/conf
index d23880eb5535..da7d6fae92eb 100644
--- a/mpd.conf
+++ b/conf
@@ -1,6 +1,5 @@
# See: /usr/share/doc/mpd/mpdconf.example
-user "mpd"
pid_file "/run/mpd/mpd.pid"
db_file "/var/lib/mpd/mpd.db"
state_file "/var/lib/mpd/mpdstate"
diff --git a/mpd-system.socket b/mpd-system.socket
deleted file mode 100644
index b43507fe0e23..000000000000
--- a/mpd-system.socket
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Music Player Daemon socket
-After=sound.target
-
-[Socket]
-ListenStream=6600
-Service=mpd.service
-
-[Install]
-WantedBy=sockets.target
diff --git a/mpd-user.socket b/mpd-user.socket
deleted file mode 100644
index 52bc762d77d8..000000000000
--- a/mpd-user.socket
+++ /dev/null
@@ -1,9 +0,0 @@
-[Unit]
-Description=Music Player Daemon socket
-
-[Socket]
-ListenStream=6600
-Service=mpd.service
-
-[Install]
-WantedBy=default.target
diff --git a/mpd.install b/mpd.install
deleted file mode 100644
index 261b8fd0d44a..000000000000
--- a/mpd.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- getent group mpd &>/dev/null || groupadd -r -g 45 mpd >/dev/null
- getent passwd mpd &>/dev/null || useradd -r -u 45 -g mpd -d /var/lib/mpd -s /bin/false -G audio mpd >/dev/null
- true
-}
-
-post_remove() {
- getent passwd mpd &>/dev/null && userdel mpd >/dev/null
- getent group mpd &>/dev/null && groupdel mpd >/dev/null
- true
-}
diff --git a/mpd.service b/mpd.service
deleted file mode 100644
index c2ee8e7e639b..000000000000
--- a/mpd.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=Music Player Daemon
-
-[Service]
-ExecStart=/usr/bin/mpd --no-daemon
-
-[Install]
-WantedBy=default.target
diff --git a/mpd.tmpfile b/mpd.tmpfile
deleted file mode 100644
index 41c4e743a3a1..000000000000
--- a/mpd.tmpfile
+++ /dev/null
@@ -1 +0,0 @@
-d /run/mpd 0755 mpd mpd
diff --git a/sysusers.d b/sysusers.d
new file mode 100644
index 000000000000..58d47478ea69
--- /dev/null
+++ b/sysusers.d
@@ -0,0 +1,2 @@
+u mpd 45 - /var/lib/mpd
+m mpd audio
diff --git a/tmpfiles.d b/tmpfiles.d
new file mode 100644
index 000000000000..bef72182b228
--- /dev/null
+++ b/tmpfiles.d
@@ -0,0 +1,3 @@
+d /run/mpd 0755 mpd mpd
+d /var/lib/mpd 0755 mpd mpd
+d /var/lib/mpd/playlists 0755 mpd mpd