summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-09-25 10:42:26 +0200
committerwillemw122015-09-25 10:45:46 +0200
commitfe3b6c82b40aec47ccf2609732735ae1b1573bfc (patch)
treedbfd6ed62bf8333b9c63ea43b798144b82fb9ac8
downloadaur-fe3b6c82b40aec47ccf2609732735ae1b1573bfc.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD57
-rw-r--r--exmplayer-git.install11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..448ed5da3675
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v7
+# Fri Sep 25 08:45:33 UTC 2015
+pkgbase = exmplayer-git
+ pkgdesc = MPlayer GUI with thumbnail seeking, 3D Video support, ... (git version)
+ pkgver = 92.1ccb1ac
+ pkgrel = 1
+ url = http://exmplayer.sourceforge.net/
+ install = exmplayer-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = mplayer
+ provides = exmplayer
+ conflicts = exmplayer
+ source = exmplayer-git::git+https://github.com/rupeshs/ExMplayer.git
+ md5sums = SKIP
+
+pkgname = exmplayer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf85987b3296
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: rtfreedman <rob<d0t>til<d0t>freedman< T>googlemail<d0t>com>
+#
+pkgname=exmplayer-git
+pkgver=92.1ccb1ac
+pkgrel=1
+url='http://exmplayer.sourceforge.net/'
+pkgdesc='MPlayer GUI with thumbnail seeking, 3D Video support, ... (git version)'
+license=('GPL')
+#
+arch=('i686' 'x86_64')
+depends=('mplayer')
+makedepends=('git')
+#
+provides=('exmplayer')
+conflicts=('exmplayer')
+#
+install="${pkgname}.install"
+
+source=("exmplayer-git::git+https://github.com/rupeshs/ExMplayer.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+prepare() {
+ cd "${pkgname}"
+# patch -p0 -i "$srcdir/qtlocalpeer.patch"
+# sed -i 's/QMAKE=qmake/QMAKE=qmake-qt4/' Makefile
+}
+
+build() {
+ cd "${pkgname}/src"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 src/exmplayer "$pkgdir"/usr/bin/exmplayer
+ #
+ install -dm755 "$pkgdir"/usr/share/applications
+ install -m644 exmplayer.desktop exmplayer_enqueue.desktop "$pkgdir"/usr/share/applications
+ install -Dm644 debian/exmplayer.png "$pkgdir"/usr/share/pixmaps/exmplayer.png
+ #
+ install -dm755 "$pkgdir"/etc/exmplayer
+ install -m644 linux_build/{sc_default.xml,fmts} "$pkgdir"/etc/exmplayer
+ #
+ install -dm755 "$pkgdir"/usr/share/exmplayer
+ # use native installed ffmpeg
+ ln -s /usr/bin/ffmpeg "$pkgdir"/usr/share/exmplayer/ffmpeg
+ # or bundled ffmpeg
+ #install -m755 linux_build/ffmpeg "$pkgdir"/usr/share/exmplayer
+}
diff --git a/exmplayer-git.install b/exmplayer-git.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/exmplayer-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}