summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2019-03-17 08:21:38 +0300
committersurefire2019-03-17 08:21:38 +0300
commitfe4bac50fdf97c078af3563034ec8a8b7c9071af (patch)
tree9d33dc4f9af01943063c0b58aeea5ce8b12b8521
parentd620ad1d06bd810978e134f7905d84367b232016 (diff)
downloadaur-fe4bac50fdf97c078af3563034ec8a8b7c9071af.tar.gz
Bump to v23.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a2af0ef140f..c43f7af331f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gnome-shell-extension-appindicator-git
pkgdesc = Integrates AppIndicators into GNOME Shell
- pkgver = 21+15+g7bd97d4
+ pkgver = 23.1+0+g03ccc3c
pkgrel = 1
epoch = 1
url = https://github.com/ubuntu/gnome-shell-extension-appindicator
arch = any
license = GPL
makedepends = git
- depends = gnome-shell
+ depends = gnome-shell>=3.32
optdepends = libappindicator-gtk2: support GTK+2 applications
optdepends = libappindicator-gtk3: support GTK+3 applications
optdepends = libappindicator-sharp: support .net applications
diff --git a/PKGBUILD b/PKGBUILD
index a9ec2dc24df8..ea60293d2c2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,40 @@
-# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+# Maintainer: Surefire <surefire at cryptomile dot net>
+# Contributor: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
# Contributor: Dave Kleinschmidt <dave.f.kleinschmidt at gmail dot com>
# Contributor: Frikilinux <frikilinux at gmail dot com>
-# Contributor: Surefire <surefire at cryptomile.net>
pkgname=gnome-shell-extension-appindicator-git
-pkgver=21+15+g7bd97d4
+pkgver=23.1+0+g03ccc3c
pkgrel=1
epoch=1
pkgdesc="Integrates AppIndicators into GNOME Shell"
arch=('any')
url="https://github.com/ubuntu/gnome-shell-extension-appindicator"
-conflicts=('gnome-shell-extension-appindicator')
-provides=('gnome-shell-extension-appindicator')
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
license=('GPL')
makedepends=('git')
-depends=('gnome-shell')
+depends=('gnome-shell>=3.32')
optdepends=(
'libappindicator-gtk2: support GTK+2 applications'
'libappindicator-gtk3: support GTK+3 applications'
'libappindicator-sharp: support .net applications'
)
-source=("${pkgname}::git+https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
+source=("${pkgname}::git+${url}.git")
sha512sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/^v//;s/-/+/g'
+ git describe --long --tags | sed 's/^v//; s/-/+/g'
}
package() {
cd "${pkgname}"
# Locate the extension.
- local _extname="$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)"
- local _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ local _uuid="$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)"
+ local _destdir="$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
# Copy extension files into place.
- install -Dm644 -t "${_destdir}" ./*.js metadata.json
- install -Dm644 -t "${_destdir}/interfaces-xml" ./interfaces-xml/*.xml
+ install -d "$_destdir"
+ cp --parents -t "$_destdir" metadata.json *.js interfaces-xml/*.xml
}