summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosiah Schwab2015-08-25 09:58:43 -0700
committerJosiah Schwab2015-08-25 09:58:43 -0700
commitfe5aba5a1ce2223064430046bde24ce0f50c3d41 (patch)
treed8bddb7455d19b2e2ebad39fe89ee505735ca645
downloadaur-fe5aba5a1ce2223064430046bde24ce0f50c3d41.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--texlive-mnras.install20
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a63faad240b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = texlive-mnras
+ pkgdesc = Package for preparing papers in the journal Monthly Notices of the Royal Astronomical Society
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://mirrors.ctan.org/macros/latex/contrib/mnras
+ install = texlive-mnras.install
+ arch = i686
+ arch = x86_64
+ depends = texlive-core
+ provides = texlive-mnras
+ source = http://mirrors.ctan.org/macros/latex/contrib/mnras.zip
+ sha1sums = 27b90967243e7284b982c23f7749182836fac398
+
+pkgname = texlive-mnras
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93514e1c7fea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Original author: Josiah Schwab <jschwab at gmail dot com>
+# Maintainer: Josiah Schwab <jschwab at gmail dot com>
+
+pkgname=texlive-mnras
+pkgdesc="Package for preparing papers in the journal Monthly Notices of the Royal Astronomical Society"
+pkgver=3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://mirrors.ctan.org/macros/latex/contrib/mnras"
+depends=('texlive-core')
+provides=('texlive-mnras')
+install=texlive-mnras.install
+source=('http://mirrors.ctan.org/macros/latex/contrib/mnras.zip')
+sha1sums=('27b90967243e7284b982c23f7749182836fac398')
+
+package() {
+ cd "$srcdir/mnras"
+
+ # install current files (v3)
+ install -Dm644 mnras.cls $pkgdir/usr/share/texmf-dist/tex/latex/mnras/mnras.cls
+ install -Dm644 mnras.bst $pkgdir/usr/share/texmf-dist/bibtex/bst/mnras/mnras.bst
+
+ # install legacy files (v2.2)
+ install -Dm644 legacy/mn2e.cls $pkgdir/usr/share/texmf-dist/tex/latex/mnras/mn2e.cls
+ install -Dm644 legacy/mn2e.bst $pkgdir/usr/share/texmf-dist/bibtex/bst/mnras/mn2e.bst
+
+}
diff --git a/texlive-mnras.install b/texlive-mnras.install
new file mode 100644
index 000000000000..17af1938dfbb
--- /dev/null
+++ b/texlive-mnras.install
@@ -0,0 +1,20 @@
+post_install() {
+ post_remove
+ echo "The mnras.bst file was installed in:"
+ kpsewhich mnras.bst
+ echo "The mnras.cls file was installed in:"
+ kpsewhich mnras.cls
+ echo "The mn2e.bst file was installed in:"
+ kpsewhich mn2e.bst
+ echo "The mnras.cls file was installed in:"
+ kpsewhich mn2e.cls
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}