summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2021-04-09 12:53:07 +0200
committerSebastian Wiesner2021-04-09 12:53:07 +0200
commitfe6ac57e0034da4a0491f2a2dabb41d44c39e5f7 (patch)
treef603927b8be5be98a83bcb7069d7f2d89cc17ed1
parentc24c7cf65c08dbfcb9efdade845f064195677c9b (diff)
downloadaur-fe6ac57e0034da4a0491f2a2dabb41d44c39e5f7.tar.gz
upgpkg: zsa-wally-cli 2.0.0-4
Replace binary package with source package
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore8
-rw-r--r--50-wally-cli.rules10
-rw-r--r--PKGBUILD37
4 files changed, 43 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b0f93975fa0..61b2ac27f9ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = zsa-wally-cli
pkgdesc = Wally: Flash your ZSA Keyboard the EZ way.
pkgver = 2.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/zsa/wally-cli
arch = i686
arch = x86_64
- license = MIT
+ license = unknown
+ makedepends = go
depends = libusb
provides = wally-cli
- source = wally-cli-2.0.0-3::https://github.com/zsa/wally-cli/releases/download/2.0.0-linux/wally-cli
+ source = zsa-wally-cli-2.0.0.tar.gz::https://github.com/zsa/wally-cli/archive/refs/tags/2.0.0-linux.tar.gz
source = 50-wally-cli.rules
- sha256sums = a38f731cc1a89d32a5cb9e377d2ec24280cb5d2fc0b34b1cb05464305fb38800
- sha256sums = SKIP
+ sha256sums = 2641c7deededeeba1aecf6b3ae3e87050a0cfd81c8b41323b2304ebe21e61745
+ sha256sums = fb0486730617d8ef8524229fda63d256a61097ab2503e865edf5c7116d57df7d
pkgname = zsa-wally-cli
diff --git a/.gitignore b/.gitignore
index 8eefd4365671..43519807e236 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,6 @@
-zsa-wally-cli-*.pkg.tar.zst
-wally-cli-*
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.patch
+!/*.rules
diff --git a/50-wally-cli.rules b/50-wally-cli.rules
index d4f6389278e7..59d7372311f3 100644
--- a/50-wally-cli.rules
+++ b/50-wally-cli.rules
@@ -1,10 +1,8 @@
# Teensy rules for the Ergodox EZ Original / Shine / Glow
ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789A]?", ENV{MTP_NO_PROBE}="1"
-SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", MODE:="0666"
-KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", MODE:="0666"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789ABCD]?", TAG+="uaccess", TAG+="udev-acl"
+KERNEL=="ttyACM*", ATTRS{idVendor}=="16c0", ATTRS{idProduct}=="04[789B]?", TAG+="uaccess", TAG+="udev-acl"
-# STM32 rules for the Planck EZ Standard / Glow
-SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", \
- MODE:="0666", \
- SYMLINK+="stm32_dfu"
+# STM32 rules for the Moonlander and Planck EZ Standard / Glow
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", TAG+="uaccess", TAG+="udev-acl", SYMLINK+="stm32_dfu"
diff --git a/PKGBUILD b/PKGBUILD
index ad85eec7d9f3..1186e6bbb8b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,39 @@
-# Maintainer: Jiří Prokop <jprokop@synaptiko.cz>
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
pkgname=zsa-wally-cli
pkgver=2.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally-cli"
-license=('MIT')
+# See https://github.com/zsa/wally-cli/issues/6
+#license=('MIT')
+license=('unknown')
depends=('libusb')
+makedepends=('go')
provides=('wally-cli')
-source=("wally-cli-$pkgver-$pkgrel::https://github.com/zsa/wally-cli/releases/download/2.0.0-linux/wally-cli"
- '50-wally-cli.rules'
-)
-sha256sums=('a38f731cc1a89d32a5cb9e377d2ec24280cb5d2fc0b34b1cb05464305fb38800'
- 'SKIP'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/zsa/wally-cli/archive/refs/tags/$pkgver-linux.tar.gz"
+ '50-wally-cli.rules'
)
+sha256sums=('2641c7deededeeba1aecf6b3ae3e87050a0cfd81c8b41323b2304ebe21e61745'
+ 'fb0486730617d8ef8524229fda63d256a61097ab2503e865edf5c7116d57df7d')
+
+build() {
+ cd "wally-cli-$pkgver-linux"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+
+ go build
+}
package() {
- install -Dm644 50-wally-cli.rules "$pkgdir"/usr/lib/udev/rules.d/50-wally-cli.rules
- install -Dm755 wally-cli-$pkgver-$pkgrel "$pkgdir"/usr/bin/wally-cli
+ cd "wally-cli-$pkgver-linux"
+
+ install -Dm755 wally-cli "$pkgdir/usr/bin/wally-cli"
+ # Not present yet, see https://github.com/zsa/wally-cli/issues/6
+ #install -Dm644 license.md "$pkgdir/usr/share/licenses/$pkgname/license.md"
}