summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-08-27 09:36:28 +0300
committerChristoph Gysin2015-08-27 09:36:28 +0300
commitfe7c91f09130780d6a4a2d734ba7c7d09f28b507 (patch)
tree46800b612c274ac744cf197c3333988657050331
downloadaur-fe7c91f09130780d6a4a2d734ba7c7d09f28b507.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
-rw-r--r--lttng-ust-git.install14
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06def45ea016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lttng-ust-git
+ pkgdesc = Userspace tracing library for LTTng
+ pkgver = 2.7.0.rc1.28.g0dafcd6
+ pkgrel = 1
+ url = http://lttng.org/
+ install = lttng-ust-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = git
+ depends = liburcu>=0.7.2
+ depends = util-linux
+ optdepends = babeltrace
+ provides = lttng-ust
+ conflicts = lttng-ust
+ options = !libtool
+ source = git://git.lttng.org/lttng-ust.git
+ sha1sums = SKIP
+
+pkgname = lttng-ust-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..de3a08e1bf40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar.*
+/lttng-ust/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35c3cac545b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Christian Babeux <christian.babeux@0x80.ca>
+
+pkgname=lttng-ust-git
+_gitname="lttng-ust"
+pkgver=2.7.0.rc1.28.g0dafcd6
+pkgrel=1
+pkgdesc="Userspace tracing library for LTTng"
+arch=('i686' 'x86_64')
+url="http://lttng.org/"
+license=('GPL2' 'LGPL2.1')
+depends=('liburcu>=0.7.2' 'util-linux')
+makedepends=('git')
+provides=('lttng-ust')
+conflicts=('lttng-ust')
+optdepends=('babeltrace')
+options=('!libtool')
+install='lttng-ust-git.install'
+source=('git://git.lttng.org/lttng-ust.git')
+sha1sums=('SKIP')
+
+pkgver()
+{
+ cd $_gitname
+ git describe --always | sed 's/-/./g;s/^v//'
+}
+
+build()
+{
+ cd $_gitname
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd $_gitname
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/lttng-ust-git.install b/lttng-ust-git.install
new file mode 100644
index 000000000000..e71b58aa9d43
--- /dev/null
+++ b/lttng-ust-git.install
@@ -0,0 +1,14 @@
+post_install()
+{
+ ldconfig
+}
+
+post_upgrade()
+{
+ ldconfig
+}
+
+post_remove()
+{
+ ldconfig
+}