summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbrarSyed2022-04-14 16:09:05 -0500
committerAbrarSyed2022-04-14 16:09:05 -0500
commitfe846c13407944fa2153f955ef2a17887a3f87ea (patch)
tree1d0660294c9127b7dfad0cf26e330920224d79c4
parent2383370541f3b091eb25dbc253c88fb5550454a4 (diff)
downloadaur-fe846c13407944fa2153f955ef2a17887a3f87ea.tar.gz
updated to v8.3.0 and added completion script
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb9970f6989d..f613bd45e998 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = cloudfoundry-cli
pkgdesc = The official command line client for Cloud Foundry
- pkgver = 7.4.0
+ pkgver = 8.3.0
pkgrel = 1
url = https://github.com/cloudfoundry/cli
arch = x86_64
license = Apache
+ provides = cf
options = !emptydirs
options = !strip
- source = cf-cli-7.4.0-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=7.4.0&source=github-rel
- md5sums = 132fd88b2c233e8feb92fdf37a1beab7
- sha256sums = 7a78614b2bb58e633d9488a357871c3ce2cc1b70b08f3e56d2bb9c82505565f9
- sha512sums = c852aa80e50d332e392a7ace34c78275994a736e476856041be16f0eb90fa2d0faabcb41142bfffb1a388f9f10097ab717ad4ae87eac4726d8a4b5807cf674af
+ source = cf-cli-8.3.0-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=8.3.0&source=github-rel
+ source = cf-cli-completion::https://raw.githubusercontent.com/cloudfoundry/cli-ci/master/ci/installers/completion/cf
+ md5sums = aa3d07847b4081d03ff1bc162f7cbe6d
+ md5sums = b3dc7a45905e0dc58f3011f431befb90
+ sha256sums = 5d2e9b1ef129a84a63f2fc6c429146c7b23ea8dba172a8b1c6f1cb1c8867eb0e
+ sha256sums = f3f05a2414075c00b101b05f73cf260b9eec9966659adf2957c1b2937bd4c48e
+ sha512sums = 229dab36d1fdaadad933761c0ea7de2fafde66492be9b6b10018c7cf0d45428a42298a1ecfcc1a9052d5dc1633e26658eba01116becf63631fb23cdccacc80e6
+ sha512sums = 016e999430d8c78ed06eb283f31ed601d6d6fb5ee2da9253f84e2364a13fe1723dfd9501f6bf53019ef6f1b54eb8e094e11564ed3d154a475a43321a99d080ef
pkgname = cloudfoundry-cli
diff --git a/PKGBUILD b/PKGBUILD
index 00da9e8bd620..ecdd78290e0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
-# Maintainer: AbrarSyed <aur@abrarsyed.com>
+# Maintainer: AbrarSyed <aur _AT_ abrarsyed _DOT_ com>
pkgname=cloudfoundry-cli
-pkgver=7.4.0
+pkgver=8.3.0
pkgrel=1
pkgdesc="The official command line client for Cloud Foundry"
arch=('x86_64')
url="https://github.com/cloudfoundry/cli"
license=('Apache')
-provides=()
+provides=(cf)
options=('!emptydirs' '!strip')
-source=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
+source=(
+ "cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel"
+ "cf-cli-completion::https://raw.githubusercontent.com/cloudfoundry/cli-ci/master/ci/installers/completion/cf"
+)
-md5sums=('a66ceec6a5aec43de5d283799acc1022')
-sha256sums=('6ac44598c580fe24c98f3b52df2e6357116478c68dee5c74800cb39cba421695')
-sha512sums=('966b5afa7b0bcba1e2dd2035d7311de2a6e56a68aa768a0e9020fe51e7a1932f2e29ec59f6959dfd3e48a6ab3b2945bd049a0b68b2c269097813157df0b98d1e')
+md5sums=('aa3d07847b4081d03ff1bc162f7cbe6d'
+ 'b3dc7a45905e0dc58f3011f431befb90')
+sha256sums=('5d2e9b1ef129a84a63f2fc6c429146c7b23ea8dba172a8b1c6f1cb1c8867eb0e'
+ 'f3f05a2414075c00b101b05f73cf260b9eec9966659adf2957c1b2937bd4c48e')
+sha512sums=('229dab36d1fdaadad933761c0ea7de2fafde66492be9b6b10018c7cf0d45428a42298a1ecfcc1a9052d5dc1633e26658eba01116becf63631fb23cdccacc80e6'
+ '016e999430d8c78ed06eb283f31ed601d6d6fb5ee2da9253f84e2364a13fe1723dfd9501f6bf53019ef6f1b54eb8e094e11564ed3d154a475a43321a99d080ef')
package() {
# copy binary
mkdir -p "$pkgdir/usr/bin"
- install $srcdir/cf "$pkgdir/usr/bin"
+ install $srcdir/cf8 "$pkgdir/usr/bin"
+ ln -s /usr/bin/cf8 "$pkgdir/usr/bin/cf"
+
+ # copy completion file, ripped from Pappy's CF6 PKGBUILD
+ install -Dm644 cf-cli-completion $pkgdir/usr/share/bash-completion/completions/cf
#copy license & notice
mkdir -p "$pkgdir/usr/share/doc/cf-cli"