summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFalko Galperin2022-01-15 23:35:48 +0100
committerFalko Galperin2022-01-15 23:35:48 +0100
commitfead4a4b24f0f27f48c5a7762712592ddfbb8221 (patch)
tree2690649503a37a8ff4e64d9813a2942d11bd3e96
parent1126d5ce248c6d6b8ce29cae5f05e88c4eb7bd35 (diff)
downloadaur-fead4a4b24f0f27f48c5a7762712592ddfbb8221.tar.gz
Update to upstream's 0.9.11
I've also added a dependency on python-cssselect until FS#73374 is resolved and added a previously missing dependency on python-cryptodome.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD7
-rw-r--r--paper2remarkable.changelog.md7
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fe91ee0a6b8..ffa224a708ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = paper2remarkable
pkgdesc = Easily download an academic paper and send it to a reMarkable.
- pkgver = 0.9.10
+ pkgver = 0.9.11
pkgrel = 1
url = https://github.com/GjjvdBurg/paper2remarkable
install = paper2remarkable.install
@@ -24,9 +24,12 @@ pkgbase = paper2remarkable
depends = python-requests>=2.21
depends = python-titlecase>=0.12
depends = python-unidecode>=1.1
- depends = python-weasyprint>=51
+ depends = python-weasyprint>=51,
+ depends = python-cloudscraper>=1.2.58
+ depends = python-pycryptodome
+ depends = python-cssselect
optdepends = python-readabilipy: Improves output of web articles
- source = https://files.pythonhosted.org/packages/source/p/paper2remarkable/paper2remarkable-0.9.10.tar.gz
- sha256sums = 5087553c4fecee913bff0c9af802bb572097f11e0ef6f200984e705f62b0d5e5
+ source = https://files.pythonhosted.org/packages/source/p/paper2remarkable/paper2remarkable-0.9.11.tar.gz
+ sha256sums = b032adeabf72d04b3dd4bf8f91c305850fd865b3eabc2efaf0ae2f6ea23b6be3
pkgname = paper2remarkable
diff --git a/PKGBUILD b/PKGBUILD
index e97916055b51..6892658f4d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Falko Galperin <dr (dot) asasteghof (at) gmail (dot) com>
pkgname=paper2remarkable
-pkgver=0.9.10
+pkgver=0.9.11
pkgrel=1
pkgdesc="Easily download an academic paper and send it to a reMarkable."
arch=(any)
@@ -12,13 +12,14 @@ depends=('python>=3.6.0' 'qpdf' 'ghostscript' 'poppler' 'rmapi' 'python-pikepdf>
'python-beautifulsoup4>=4.8' 'python-html2text>=2020.1.16' 'python-markdown>=3.1.1'
'python-pdfplumber>=0.5' 'python-yaml>=5.1' 'python-readability-lxml>=0.7.1'
'python-regex>=2018.11' 'python-requests>=2.21' 'python-titlecase>=0.12'
-'python-unidecode>=1.1' 'python-weasyprint>=51')
+'python-unidecode>=1.1' 'python-weasyprint>=51', 'python-cloudscraper>=1.2.58'
+'python-pycryptodome' 'python-cssselect')
makedepends=('python-setuptools')
optdepends=('python-readabilipy: Improves output of web articles')
changelog=$pkgname.changelog.md
install=$pkgname.install
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=("1bbf18246b04972f11417e817e6ca863764303191acac17cab0e9d02dc47ee7d")
+sha256sums=("b032adeabf72d04b3dd4bf8f91c305850fd865b3eabc2efaf0ae2f6ea23b6be3")
build() {
cd "$pkgname-$pkgver/"
diff --git a/paper2remarkable.changelog.md b/paper2remarkable.changelog.md
index 7955b2a8fa93..5815677c2830 100644
--- a/paper2remarkable.changelog.md
+++ b/paper2remarkable.changelog.md
@@ -1,3 +1,10 @@
+# Changelog
+
+## Version 0.9.11
+
+* Bugfix for SagePub provider
+* Enable Taylor & Francis provider again
+
## Version 0.9.10
* Bugfix for ACM provider