summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-24 10:25:49 -0700
committeryochananmarqos2020-01-24 10:25:49 -0700
commitfebb8298d474f691493df99b27d20422741085d5 (patch)
treea79244c0e1fe2a5c843a97894a6fe56d668a8e30
parent55bfc425aa6611f6095006dac8049730952ad61f (diff)
downloadaur-febb8298d474f691493df99b27d20422741085d5.tar.gz
fix build & update dependencies, etc.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD82
-rw-r--r--lighttable.desktop10
4 files changed, 69 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a4fb06070f9..981eacd60378 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,26 @@
pkgbase = lighttable-git
pkgdesc = Next generation code editor and IDE with instant feedback.
- pkgver = 0.8.1.r49.g5db6b70
+ pkgver = 0.8.1.r114.g3760844
pkgrel = 1
- url = http://lighttable.com/
- arch = x86_64
+ url = http://lighttable.com
arch = i686
+ arch = x86_64
license = MIT
+ makedepends = git
makedepends = npm
makedepends = leiningen
- depends = alsa-lib
depends = gconf
- depends = gtk2
- depends = java-environment
- depends = libnotify
- depends = nodejs
+ depends = gtk3
depends = nss
- depends = libxtst
+ depends = libxss
+ depends = java-runtime
provides = lighttable
- conflicts = lighttable-bin
- source = git://github.com/LightTable/LightTable.git
+ conflicts = lighttable
+ conflicts = lighttable-git-bin
+ source = lighttable::git+https://github.com/LightTable/LightTable.git
source = lighttable.desktop
sha256sums = SKIP
- sha256sums = 3ed905cba2906c138016e53d9b9327bf933c8e96f649b50b3a479ec32045d1e1
+ sha256sums = e03434b57de5e29c8a64e2d3877339254e08899c4784e256d5eede939199cf70
pkgname = lighttable-git
diff --git a/.gitignore b/.gitignore
index 577aca401a50..bd9655ec176b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,8 @@
-*.pkg.tar.xz
-LightTable
-src
-pkg
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!lighttable.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 15a6a0de27bf..ef1239e1a92d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,58 @@
-# Maintainer: Conor Anderson <conor@conr.ca>
+# Maintainer: FabioLolix <fabio dot loli at disroot dot org>
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Conor Anderson <conor at conr dot ca>
pkgname=lighttable-git
-_pkgname="${pkgname%-git}"
-_name=LightTable
-pkgver=0.8.1.r49.g5db6b70
-_pkgver=${pkgver/%.r*/}
+pkgver=0.8.1.r114.g3760844
pkgrel=1
-pkgdesc='Next generation code editor and IDE with instant feedback.'
-arch=('x86_64' 'i686')
-url='http://lighttable.com/'
+pkgdesc="Next generation code editor and IDE with instant feedback."
+arch=('i686' 'x86_64')
+url="http://lighttable.com"
license=('MIT')
-conflicts=('lighttable-bin')
-depends=('alsa-lib' 'gconf' 'gtk2' 'java-environment' 'libnotify' 'nodejs' 'nss' 'libxtst')
-makedepends=('npm' 'leiningen')
-provides=('lighttable')
-source=("git://github.com/LightTable/LightTable.git"
- "lighttable.desktop")
+depends=('gconf' 'gtk3' 'nss' 'libxss' 'java-runtime')
+makedepends=('git' 'npm' 'leiningen')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" "$pkgname-bin")
+source=("${pkgname%-git}::git+https://github.com/LightTable/LightTable.git"
+ "${pkgname%-git}.desktop")
sha256sums=('SKIP'
- '3ed905cba2906c138016e53d9b9327bf933c8e96f649b50b3a479ec32045d1e1')
+ 'e03434b57de5e29c8a64e2d3877339254e08899c4784e256d5eede939199cf70')
pkgver() {
- cd "${srcdir}/${_name}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Use temporary npm cache
+ mkdir -p npm-cache
+ sed -i 's|npm install|npm install --cache ../../npm-cache|g' script/build.sh
}
build() {
- cd "${srcdir}/${_name}"
- script/build.sh
+ cd "$srcdir/${pkgname%-git}"
+ script/build.sh
}
package() {
- # Place files
- install -d "${pkgdir}/usr/lib/${_pkgname}"
- cp -a "${srcdir}/${_name}/builds/${_pkgname}-${_pkgver}-linux/"* "${pkgdir}/usr/lib/${_pkgname}"
-
- # Symlink main binary
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/lib/${_pkgname}/${_name}" "${pkgdir}/usr/bin/${_pkgname}"
-
- # Place desktop entry and icon
- desktop-file-install -m 644 --dir "${pkgdir}/usr/share/applications/" "${_pkgname}.desktop"
- install -Dm644 "${srcdir}/${_name}/deploy/core/img/lticon.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
-
- # Place license files
- for license in "LICENSE" "LICENSES.chromium.html"; do
- install -Dm644 "${pkgdir}/usr/lib/${_pkgname}/${license}" "${pkgdir}/usr/share/licenses/${_pkgname}/${license}"
- rm "${pkgdir}/usr/lib/${_pkgname}/${license}"
- done
-}
+ cd "$srcdir/${pkgname%-git}"
+
+ # Place main files
+ install -d "$pkgdir/opt/${pkgname%-git}"
+ cp -a "builds/${pkgname%-git}-0.9.0-linux"/* "$pkgdir/opt/${pkgname%-git}"
+ # Link to binary
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname%-git}/LightTable" "$pkgdir/usr/bin/${pkgname%-git}"
+
+ # Install desktop file
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications"
+
+ # Install icon
+ install -Dm644 deploy/core/img/lticon.png "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+
+ # Install license in proper location
+ install -dm644 "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ mv "$pkgdir/opt/${pkgname%-git}/LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+}
diff --git a/lighttable.desktop b/lighttable.desktop
index f5d62a5c12ce..77f7b36db2fe 100644
--- a/lighttable.desktop
+++ b/lighttable.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
+Version=0.8.1
Name=Light Table
-Comment=Light Table IDE
-Type=Application
-Icon=lighttable
+GenericName=Source Code Editor
Exec=lighttable
-Categories=Utility;TextEditor;Development
Terminal=false
-MimeType=text/plain;
+Icon=lighttable
+Type=Application
+Categories=GTK;Utility;TextEditor;Application;IDE;Development;