summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMicah Halter2020-01-28 12:33:43 -0500
committerMicah Halter2020-01-28 12:33:43 -0500
commitfed0848356d56b4c9e1dbee8bac966d809b66e8a (patch)
tree7dc854eb1b1f87a18a5a5dadba07d99007e83689
parent857ff4d5c6551b6ae5450f634bc6a13f3909b5d6 (diff)
downloadaur-fed0848356d56b4c9e1dbee8bac966d809b66e8a.tar.gz
Updated openscap to 1.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76fae881d680..a9259296dd14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openscap
pkgdesc = Open Source Security Compliance Solution
- pkgver = 1.2.17
- pkgrel = 3
+ pkgver = 1.3.2
+ pkgrel = 1
url = https://www.open-scap.org/
arch = x86_64
license = GPL
@@ -24,8 +24,8 @@ pkgbase = openscap
depends = perl
depends = perl-xml-parser
depends = perl-xml-xpath
- source = https://github.com/OpenSCAP/openscap/releases/download/1.2.17/openscap-1.2.17.tar.gz
- md5sums = 56d11d9bd3d61b6edf7368636344ff72
+ source = https://github.com/OpenSCAP/openscap/releases/download/1.3.2/openscap-1.3.2.tar.gz
+ md5sums = f5d6f3b7a28a8896d7641ca24ca9d743
pkgname = openscap
diff --git a/PKGBUILD b/PKGBUILD
index 624827b520f3..a4413ecd51da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
+# Maintainer: mehalter <micah at mehalter.com>
+# Maintainer: OpenPrivacy <maildrop AT comedia DOT com>
# Maintainer: Cyrinux <pkgbuilds AT levis DOT name>
# Maintainer: Quey-Liang Kao <s101062801@m101.nthu.edu.tw>
pkgname=openscap
-pkgver=1.2.17
-pkgrel=3
+pkgver=1.3.2
+pkgrel=1
pkgdesc="Open Source Security Compliance Solution"
# i686 is theoretically bulitable, if anyone needs it
@@ -12,7 +14,7 @@ url="https://www.open-scap.org/"
license=('GPL')
# The official site suggested the dependencies in terms of Fedora's rpm.
-# Some of the corresponding packages in Arch remain unclear, which are listed
+# Some of the corresponding packages in Arch remain unclear, which are listed
# here for now.
# packege missing: libselinux-devel
depends=('swig' 'python' 'acl' 'libcap' 'curl' 'libgcrypt' 'libxml2' 'libxslt'
@@ -20,26 +22,24 @@ depends=('swig' 'python' 'acl' 'libcap' 'curl' 'libgcrypt' 'libxml2' 'libxslt'
optdepends=()
makedepends=('doxygen' 'automake' 'acl')
source=("https://github.com/OpenSCAP/openscap/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('56d11d9bd3d61b6edf7368636344ff72')
+md5sums=('f5d6f3b7a28a8896d7641ca24ca9d743')
build() {
- cd "$pkgname-$pkgver"
- CPPFLAGS="-I/usr/include/python3.7m" ./configure --disable-valgrind --disable-python --enable-python3 --prefix=/usr
- make # -j4
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake ../
+ make
}
# Notice: It may take a long time to complete the check.
# check() {
-# cd "$pkgname-$pkgver"
-# make check
+# cd "$pkgname-$pkgver"
+# make check
#}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
-
- # That's what the guideline says.
- mv $pkgdir/usr/libexec/* $pkgdir/usr/lib/$pkgname/
- rm -fr $pkgdir/usr/libexec/
+ cd "$srcdir/${pkgname}-${pkgver}/build"
+ make DESTDIR="$pkgdir/" install
}