summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Krauskopf2015-06-17 17:58:35 +0200
committerFlorian Krauskopf2015-06-17 17:58:35 +0200
commitfedf742146d8529338c8d547262f6e181b24f087 (patch)
treefe3e92c8fd9509a2a006037143f29fb50dc017d8
downloadaur-fedf742146d8529338c8d547262f6e181b24f087.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adc8d7a20456
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-gnupg-isis
+ pkgdesc = A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.
+ pkgver = 2.0.1
+ pkgrel = 2
+ url = https://github.com/isislovecruft/python-gnupg
+ arch = any
+ license = GPL3
+ depends = python
+ depends = gnupg
+ depends = python-psutil
+ provides = python-gnupg
+ conflicts = python-gnupg
+ source = git://github.com/isislovecruft/python-gnupg.git
+ md5sums = SKIP
+
+pkgname = python-gnupg-isis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b6d74e0eb03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: KopfKrieg <archlinux [at] absolem [dot] cc>
+
+pkgname=python-gnupg-isis
+_gitname=python-gnupg
+pkgver=2.0.1
+pkgrel=2
+pkgdesc='A modified version of python-gnupg, including security patches, extensive documentation, and extra features. The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.'
+url='https://github.com/isislovecruft/python-gnupg'
+license=('GPL3')
+arch=('any')
+depends=('python' 'gnupg' 'python-psutil')
+conflicts=('python-gnupg')
+provides=('python-gnupg')
+source=('git://github.com/isislovecruft/python-gnupg.git')
+md5sums=('SKIP')
+
+build() {
+ cd $_gitname
+ git checkout $pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_gitname
+ git checkout $pkgver
+ python setup.py install --root=${pkgdir} --optimize=1
+}