summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2016-05-03 18:51:37 +0200
committerRicardo Band2016-05-03 18:51:37 +0200
commitff0bc963e4f242f4777b03e4843f9c263bf3bfd2 (patch)
tree34751f1c2936239adbfdaaf0901bc2f025818d6e
downloadaur-ff0bc963e4f242f4777b03e4843f9c263bf3bfd2.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--brother-dcp-9022cdw.install12
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4df459b5129
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-dcp-9022cdw
+ pkgdesc = LPR and CUPS driver for the Brother DCP-9022CDW
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-dcp-9022cdw.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ source = http://download.brother.com/welcome/dlf101612/dcp9022cdwlpr-1.1.3-0.i386.deb
+ source = http://download.brother.com/welcome/dlf101613/dcp9022cdwcupswrapper-1.1.3-0.i386.deb
+ sha256sums = 8db48cda7e8f38f6a9fe0279f67e6d286a300f41e7982d1be275113542ec5027
+ sha256sums = 469a31e8b2327e927a92a57635e079e504a87e864b0e51b1223fd4c184184ba6
+
+pkgname = brother-dcp-9022cdw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6309d2359223
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: dk0r <dk0r.public@gmail.com>
+
+_model="9022cdw"
+pkgname="brother-dcp-$_model"
+pkgver="1.1.3"
+pkgrel=1
+_revision=0
+pkgdesc="LPR and CUPS driver for the Brother DCP-9022CDW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+install="brother-dcp-${_model}.install"
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+source=("http://download.brother.com/welcome/dlf101612/dcp${_model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://download.brother.com/welcome/dlf101613/dcp9022cdwcupswrapper-1.1.3-0.i386.deb")
+sha256sums=('8db48cda7e8f38f6a9fe0279f67e6d286a300f41e7982d1be275113542ec5027'
+ '469a31e8b2327e927a92a57635e079e504a87e864b0e51b1223fd4c184184ba6')
+package() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "dcp${_model}" ] || (mkdir dcp${_model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C dcp${_model};done || return 1
+ cd dcp${_model} || return 1
+ cd opt/brother/Printers/dcp${_model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrapperdcp${_model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/dcp${_model}/opt/brother/Printers/dcp${_model}/inf/setupPrintcapij || return 1
+ cp -rf $srcdir/dcp${_model}/usr/ $pkgdir/ || return 1
+ cp -rf $srcdir/dcp${_model}/opt/ $pkgdir/ || return 1
+}
diff --git a/brother-dcp-9022cdw.install b/brother-dcp-9022cdw.install
new file mode 100644
index 000000000000..d3fd80fe1f6e
--- /dev/null
+++ b/brother-dcp-9022cdw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/dcp9022cdw/cupswrapper/cupswrapperdcp9022cdw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}