summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-09 10:17:19 +0800
committerzxp198210052024-02-09 10:17:19 +0800
commitff0ec876ee00169507097f38613352641e989532 (patch)
tree2d56596c3ae5575c2af5f46a18c1802b0baccf60
parent2e52b16cc182a2214635de3943cd18366c7fcd5f (diff)
downloadaur-ff0ec876ee00169507097f38613352641e989532.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--deepin-wine-quarkclouddrive.install6
-rw-r--r--deepin-wine-quarkclouddrive.sh112
4 files changed, 34 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbdf20864e51..d75b36678b2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = deepin-wine-quarkclouddrive
pkgdesc = 夸克网盘是夸克推出的一款云服务产品,可轻松进行照片、视频、文档、音频等文件的在线备份、同步和分享,并支持电脑/手机/iPad端等多个端。
pkgver = 3.0.5spark3
- pkgrel = 1
+ pkgrel = 2
url = https://pan.quark.cn/
install = deepin-wine-quarkclouddrive.install
arch = x86_64
- license = custom:freeware
- depends = deepin-wine6-stable
+ license = LicenseRef-custom
+ depends = deepin-wine8-stable
depends = spark-dwine-helper
depends = xdg-utils
depends = hicolor-icon-theme
@@ -16,11 +16,9 @@ pkgbase = deepin-wine-quarkclouddrive
conflicts = quarkclouddrive
source = deepin-wine-quarkclouddrive_3.0.5spark3_amd64.deb::https://mirrors.sdu.edu.cn/spark-store/store/network/cn.quarkclouddrive.spark/cn.quarkclouddrive.spark_3.0.5spark3_all.deb
source = LICENSE.html
- source = deepin-wine-quarkclouddrive.install
source = deepin-wine-quarkclouddrive.sh
sha256sums = a90bd9bdb07c0a77d399ef8e7ad645971824ce9114221f4a1490a883ea46ccc4
sha256sums = b8252eb8c22ea41cc43c9436f341a78cac19cbc71c3593fa1b042fc9136f6767
- sha256sums = 48e7a80b45d16321f794020aaa9be9c46ba76d2da8c52d86f6e2bbfe6abdf13b
- sha256sums = 1be688a7a5c9196bfb6657911b96235671fbe10062c437e08b5e3eccc5b561b9
+ sha256sums = 14ce939f265afc3e522bd3de9cbbfc407e609577d8e46d3fb818b76a8b3aba36
pkgname = deepin-wine-quarkclouddrive
diff --git a/PKGBUILD b/PKGBUILD
index d204fa5fe78f..06a601d43bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,18 @@ _downname=QuarkCloudDrive
_installpkgpath=quark-cloud-drive
pkgver=3.0.5spark3
_sparkpkgname="cn.${_officalname}.spark"
-pkgrel=1
+pkgrel=2
pkgdesc="夸克网盘是夸克推出的一款云服务产品,可轻松进行照片、视频、文档、音频等文件的在线备份、同步和分享,并支持电脑/手机/iPad端等多个端。"
arch=("x86_64")
url="https://pan.quark.cn/"
_downurl=https://pc.qq.com/
#_sparkdown=("https://d.store.deepinos.org.cn")
_sparkdown=("https://mirrors.sdu.edu.cn/spark-store")
-license=('custom:freeware')
+license=('LicenseRef-custom')
conflicts=("${_officalname}")
provides=("${_officalname}")
depends=(
- 'deepin-wine6-stable'
+ 'deepin-wine8-stable'
'spark-dwine-helper'
'xdg-utils'
'hicolor-icon-theme'
@@ -25,28 +25,23 @@ optdepends=(
'wqy-microhei'
'wqy-zenhei'
)
+install="${pkgname}.install"
source=(
"${pkgname}_${pkgver}_amd64.deb::${_sparkdown}/store/network/${_sparkpkgname}/${_sparkpkgname}_${pkgver}_all.deb"
"LICENSE.html"
- "${pkgname}.install"
"${pkgname}.sh"
)
-install="${pkgname}.install"
sha256sums=('a90bd9bdb07c0a77d399ef8e7ad645971824ce9114221f4a1490a883ea46ccc4'
'b8252eb8c22ea41cc43c9436f341a78cac19cbc71c3593fa1b042fc9136f6767'
- '48e7a80b45d16321f794020aaa9be9c46ba76d2da8c52d86f6e2bbfe6abdf13b'
- '1be688a7a5c9196bfb6657911b96235671fbe10062c437e08b5e3eccc5b561b9')
+ '14ce939f265afc3e522bd3de9cbbfc407e609577d8e46d3fb818b76a8b3aba36')
build() {
- sed "s|@bottlename@|${_downname}|g" -i "${srcdir}/${pkgname}.install"
sed -e "s|@appname@|${pkgname}|g" \
- -e "s|@sparkver@|${_sparkver}|g" \
-e "s|@appver@|${pkgver}|g" \
- -e "s|@installname@|${_installpkgpath}|g" \
-e "s|@bottlename@|${_downname}|g" \
-i "${srcdir}/${pkgname}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
mv "${srcdir}/opt/apps/${_sparkpkgname}" "${srcdir}/opt/apps/${pkgname}"
- sed "s|${_sparkpkgname}|${pkgname}|g;s|\"/opt/apps/${pkgname}/files/run.sh\"|${pkgname}|g" \
+ sed "s|${_sparkpkgname}|${pkgname}|g;s|\"/opt/apps/${pkgname}/files/run.sh\"|${pkgname} --no-sandbox|g" \
-i "${srcdir}/opt/apps/${pkgname}/entries/applications/${_sparkpkgname}.desktop"
rm -rf "${srcdir}/opt/apps/${pkgname}/info"
}
diff --git a/deepin-wine-quarkclouddrive.install b/deepin-wine-quarkclouddrive.install
index 8dc26b08ec85..5bbc1f971e59 100644
--- a/deepin-wine-quarkclouddrive.install
+++ b/deepin-wine-quarkclouddrive.install
@@ -7,10 +7,10 @@ post_install() {
info
}
post_upgrade() {
- find /home -maxdepth 2 -name ".deepinwine" -exec rm -f \{\}/Deepin-@bottlename@/reinstalled \;
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -f \{\}/Deepin-QuarkCloudDrive/reinstalled \;
info
}
pre_remove() {
- echo "deleting the Deepin-@bottlename@ bottle..."
- find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-@bottlename@/ \;
+ echo "deleting the Deepin-QuarkCloudDrive bottle..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-QuarkCloudDrive/ \;
} \ No newline at end of file
diff --git a/deepin-wine-quarkclouddrive.sh b/deepin-wine-quarkclouddrive.sh
index 339853cf01d3..1c3f5cc0962d 100644
--- a/deepin-wine-quarkclouddrive.sh
+++ b/deepin-wine-quarkclouddrive.sh
@@ -1,100 +1,30 @@
#!/bin/sh
-
-# Copyright (C) 2016 Deepin, Inc.
-#
-# Author: Li LongYu <lilongyu@linuxdeepin.com>
-# Peng Hao <penghao@linuxdeepin.com>
-
-version_gt() { test "$(echo "$@" | tr " " "\n" | sort -V | head -n 1)" != "$1"; }
+set -e
BOTTLENAME=Deepin-@bottlename@
-APPVER=@sparkver@
-WINEPREFIX="${HOME}/.deepinwine/${BOTTLENAME}"
-APP_INSTALLER=@installname@-@appver@.exe
-APP_INSTALLER_PATH="c:/Program Files (x86)/@installname@/${APP_INSTALLER}"
-EXEC_PATH="c:/Program Files (x86)/@installname@/@bottlename@.exe"
-EXEC_FILE="${WINEPREFIX}/drive_c/Program Files (x86)/@installname@/@bottlename@.exe"
-START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"
+APPVER=@appver@
+EXEC_PATH="c:/ProgramData/Microsoft/Windows/Start Menu/Programs/夸克网盘.lnk"
+START_SHELL_PATH="/opt/deepinwine/tools/spark_run_v4.sh"
export MIME_TYPE=""
export DEB_PACKAGE_NAME=@appname@
-export APPRUN_CMD="deepin-wine6-stable"
-DISABLE_ATTACH_FILE_DIALOG="1"
+export APPRUN_CMD=deepin-wine8-stable
+EXPORT_ENVS=""
export SPECIFY_SHELL_DIR=`dirname ${START_SHELL_PATH}`
ARCHIVE_FILE_DIR="/opt/apps/${DEB_PACKAGE_NAME}/files"
+export WINEDLLPATH="/opt/${APPRUN_CMD}/lib:/opt/${APPRUN_CMD}/lib64"
export WINEPREDLL="${ARCHIVE_FILE_DIR}/dlls"
-
-OpenWinecfg() {
- echo "Launching winecfg with ${APPRUN_CMD} in ${WINEPREFIX} ..."
- env WINEPREFIX="${WINEPREFIX}" "${APPRUN_CMD}" winecfg
-}
-
-DeployApp() {
- # deploy bottle
- echo "Deploying ${WINEPREFIX} ..."
- rm -rf "${WINEPREFIX}"
- # run installer
- echo "Launching ${APP_INSTALLER_PATH} ..."
- env WINEDLLOVERRIDES="winemenubuilder.exe=d" "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "${APP_INSTALLER_PATH}" "$@"
- touch "${WINEPREFIX}/reinstalled"
- echo "Creating ${WINEPREFIX}/PACKAGE_VERSION ..."
- cat "/opt/apps/${DEB_PACKAGE_NAME}/files/files.md5sum" > "${WINEPREFIX}/PACKAGE_VERSION"
-}
-
-WakeApp() {
- env WINEPREDLL="${ARCHIVE_FILE_DIR}/dlls" \
- WINEDLLPATH="/opt/${APPRUN_CMD}/lib:/opt/${APPRUN_CMD}/lib64" \
- WINEPREFIX="${WINEPREFIX} ${APPRUN_CMD} /opt/deepinwine/tools/sendkeys.exe w"
-}
-
-Run() {
- if [ -z "${DISABLE_ATTACH_FILE_DIALOG}" ]; then
- export ATTACH_FILE_DIALOG=1
- fi
-
- if [ -n "${EXPORT_ENVS}" ]; then
- export "${EXPORT_ENVS}"
- fi
-
- if [ -n "${EXEC_PATH}" ]; then
- if [ ! -f "${WINEPREFIX}/reinstalled" ] || [ ! -f "${EXEC_FILE}" ]; then
- DeployApp
- exit 0
- fi
-
- if [ -z "${EXEC_PATH##*.lnk*}" ]; then
- echo "Launching ${EXEC_PATH} lnk file ..."
- "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "C:/windows/command/start.exe" "/Unix" "${EXEC_PATH}" "$@"
- else
- echo "Launching $EXEC_PATH ..."
- "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "${EXEC_PATH}" "$@"
- fi
+DISABLE_ATTACH_FILE_DIALOG=""
+if [ -z "${DISABLE_ATTACH_FILE_DIALOG}" ];then
+ export ATTACH_FILE_DIALOG=1
+fi
+if [ -n "$EXPO{RT_ENVS" ];then
+ export "${EXPORT_ENVS}"
+fi
+if [ -n "${EXEC_PATH}" ];then
+ if [ -z "${EXEC_PATH##*.lnk*}" ];then
+ exec "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "C:/windows/command/start.exe" "/Unix" "${EXEC_PATH}" "$@"
else
- "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "uninstaller.exe" "$@"
+ exec "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "${EXEC_PATH}" "$@"
fi
-}
-
-HelpApp() {
- echo " Extra Commands:"
- echo " winecfg Open winecfg"
- echo " -w/--wake Wake up background program"
- echo " -h/--help Show program help info"
-}
-
-if [ -z $1 ]; then
- Run "$@"
- exit 0
-fi
-case $1 in
-"winecfg")
- OpenWinecfg
- ;;
-"-w" | "--wake")
- WakeApp
- ;;
-"-h" | "--help")
- HelpApp
- ;;
-*)
- Run "$@"
- ;;
-esac
-exit 0 \ No newline at end of file
+else
+ exec "${START_SHELL_PATH}" "${BOTTLENAME}" "${APPVER}" "uninstaller.exe" "$@"
+fi \ No newline at end of file