summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff2015-10-16 16:08:37 +0200
committerDmitrij D. Czarkoff2015-10-16 16:08:37 +0200
commitff12d4a1a917b4f179186fc9fc5d6f0cf7a85883 (patch)
tree27d064d682128677bc371ee72e326c9867f7581b
downloadaur-ff12d4a1a917b4f179186fc9fc5d6f0cf7a85883.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c562e9fc21c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rem
+ pkgdesc = portable library for real-time audio and video processing
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = http://creytiv.com/rem.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = re
+ source = http://creytiv.com/pub/rem-0.4.6.tar.gz
+ md5sums = 888c3000aa002790cc7129fa72d39a58
+
+pkgname = rem
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75cb4137f783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a56386ab8313
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+pkgname=rem
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="portable library for real-time audio and video processing"
+arch=('i686' 'x86_64')
+url="http://creytiv.com/rem.html"
+license=('BSD')
+depends=('re')
+#changelog=ChangeLog
+source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz")
+md5sums=('888c3000aa002790cc7129fa72d39a58')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}