summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Poellmann2024-01-11 01:09:44 +0000
committerDaniel Poellmann2024-01-11 01:09:44 +0000
commitff3e8f692c50e071b08d5175538b154ea9b0c978 (patch)
treed579d16f9372c70574c0eb3f5459725510af9318
parenteaaada57f92146d9076ab7f4792f8bdc00a005af (diff)
downloadaur-ff3e8f692c50e071b08d5175538b154ea9b0c978.tar.gz
5.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5189db4de10a..fb004a1f14b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = linphone-desktop
pkgdesc = A free VoIP and video softphone based on the SIP protocol
- pkgver = 5.1.2
- pkgrel = 2
+ pkgver = 5.2.0
+ pkgrel = 1
url = http://linphone.org
arch = x86_64
license = GPL
+ makedepends = meson
makedepends = coreutils
makedepends = git
makedepends = gendesk
@@ -30,7 +31,8 @@ pkgbase = linphone-desktop
depends = libxcrypt-compat
depends = v4l-utils
depends = glew
- source = git+https://github.com/BelledonneCommunications/linphone-desktop.git#commit=c3daf71
+ provides = linphone=5.2.0
+ source = git+https://github.com/BelledonneCommunications/linphone-desktop.git#commit=f656c02
source = linphone.png::https://gitlab.linphone.org/BC/public/linphone-desktop/-/raw/8dfd384e3df08b200c8eb382b740da6839961bf0/linphone-app/assets/icons/hicolor/128x128/apps/icon.png
sha512sums = SKIP
sha512sums = d6495cdc022b1e4c92b3641cb70347e7e6b6ef47599004de729e908b4876a12540713ab54b588611c99c8025fb9b33e3392573c85c13f72cdaee8bcf7a73d65d
diff --git a/PKGBUILD b/PKGBUILD
index f0a4393ccffa..68ac09705762 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,30 @@
# Contributor: David P. <megver83@parabola.nu>
pkgname=linphone-desktop
-pkgver=5.1.2
-pkgrel=2
+pkgver=5.2.0
+pkgrel=1
pkgdesc='A free VoIP and video softphone based on the SIP protocol'
arch=(x86_64)
url='http://linphone.org'
license=(GPL)
depends=('qt5-base' 'qt5-multimedia' 'qt5-graphicaleffects' 'qt5-quickcontrols' 'qt5-svg' 'qt5-speech' 'libxcrypt-compat' 'v4l-utils' 'glew')
-makedepends=('coreutils' 'git' 'gendesk' 'cmake' 'yasm' 'nasm' 'doxygen' 'perl' 'python-pystache' 'python-six' 'libpulse' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools')
-source=("git+https://github.com/BelledonneCommunications/linphone-desktop.git#commit=c3daf71"
+makedepends=('meson' 'coreutils' 'git' 'gendesk' 'cmake' 'yasm' 'nasm' 'doxygen' 'perl' 'python-pystache' 'python-six' 'libpulse' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-tools')
+source=("git+https://github.com/BelledonneCommunications/linphone-desktop.git#commit=f656c02"
"linphone.png::https://gitlab.linphone.org/BC/public/linphone-desktop/-/raw/8dfd384e3df08b200c8eb382b740da6839961bf0/linphone-app/assets/icons/hicolor/128x128/apps/icon.png"
)
sha512sums=('SKIP'
'd6495cdc022b1e4c92b3641cb70347e7e6b6ef47599004de729e908b4876a12540713ab54b588611c99c8025fb9b33e3392573c85c13f72cdaee8bcf7a73d65d'
)
options=()
+provides=(linphone=${pkgver})
-build() {
+prepare() {
cd "$srcdir/linphone-desktop"
-
git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/linphone-desktop"
mkdir -p build build/OUTPUT && cd build
cmake .. -DCMAKE_BUILD_PARALLEL_LEVEL=$(nproc) -DCMAKE_BUILD_TYPE=RelWithDebInfo