summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2019-12-19 10:36:56 +0300
committerAnton Kudelin2019-12-19 10:36:56 +0300
commitff48a2de3df570e8716cfed02e4d9e004489b98f (patch)
treeca0a21b3fea6ff8d7027d58b9b276149bdd0db90
parent69db9f772ce196357f3828f1e782f402a0fd6f50 (diff)
downloadaur-ff48a2de3df570e8716cfed02e4d9e004489b98f.tar.gz
Switched to vanilla f2c, increased version number to the last patch date
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD67
2 files changed, 59 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e2b1ec15858..9f3776dd488c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = f2c
pkgdesc = Fortran to C code translator
- pkgver = 1.0
- pkgrel = 9
+ pkgver = 20191129
+ pkgrel = 1
url = http://www.netlib.org/f2c/index.html
arch = x86_64
- arch = i686
license = custom
- makedepends = git
- source = git://github.com/juanjosegarciaripoll/f2c.git#commit=d01fe07
- md5sums = SKIP
+ depends = gcc-libs
+ noextract = libf2c.zip
+ source = https://www.netlib.org/f2c/src.tgz
+ source = https://www.netlib.org/f2c/libf2c.zip
+ sha256sums = ae76b86c5ce887ad508a761509a762adf5ccb8d9ea0c40901264aa1b994878db
+ sha256sums = ca404070e9ce0a9aaa6a71fc7d5489d014ade952c5d6de7efb88de8e24f2e8e0
pkgname = f2c
diff --git a/PKGBUILD b/PKGBUILD
index 1e4400d2098b..eb110eea9e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,68 @@
-# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: xiretza <xiretza+aur@gmail.com>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Jesin <jesin00@gmail.com>
# Contributor: Gabriele Lanaro <gabriele.lanaro@gmail.com>
pkgname=f2c
-pkgver=1.0
-pkgrel=9
+pkgver=20191129
+pkgrel=1
pkgdesc='Fortran to C code translator'
url='http://www.netlib.org/f2c/index.html'
license=('custom')
-makedepends=('git')
-arch=('x86_64' 'i686')
-source=("git://github.com/juanjosegarciaripoll/f2c.git#commit=d01fe07")
-md5sums=('SKIP')
+arch=('x86_64')
+depends=('gcc-libs')
+source=("https://www.netlib.org/f2c/src.tgz"
+ "https://www.netlib.org/f2c/libf2c.zip")
+noextract=("libf2c.zip")
+sha256sums=('ae76b86c5ce887ad508a761509a762adf5ccb8d9ea0c40901264aa1b994878db'
+ 'ca404070e9ce0a9aaa6a71fc7d5489d014ade952c5d6de7efb88de8e24f2e8e0')
prepare() {
- cd "$pkgname"
- ./autogen.sh
+ cd $srcdir
+ mv src f2c
+ mkdir libf2c
+ unzip -q libf2c.zip -d libf2c
+ sed -i "s@-O@-O -fPIC@g" libf2c/makefile.u
+ sed -i "s@xsum @$srcdir/f2c/xsum @g" libf2c/makefile.u
}
build() {
- cd "$pkgname"
- ./configure --prefix=/usr
- make
+ cd $srcdir/libf2c
+ make hadd -f makefile.u
+ make -f makefile.u
+ make -f makefile.u libf2c.so
+
+ cd $srcdir/f2c
+ make -f makefile.u
}
package() {
- make -C "$pkgname" DESTDIR="$pkgdir" install
- install -Dm644 "${pkgname}/COPYRIGHT" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
-}
+ install -dm755 $pkgdir/usr/{bin,include,lib,share/licenses/$pkgname}
+ cd $pkgdir/usr
+ install -m755 $srcdir/f2c/f2c bin
+ install -m755 $srcdir/libf2c/libf2c.so lib
+ install -m755 $srcdir/libf2c/f2c.h include
+ cat <<EOF > $pkgdir/usr/share/licenses/$pkgname/LICENSE
+Copyright 1990-1996, 2000-2001 by AT&T, Lucent Technologies and Bellcore.
-# vim:set ts=2 sw=2 et:
+Permission to use, copy, modify, and distribute this software
+and its documentation for any purpose and without fee is hereby
+granted, provided that the above copyright notice appear in all
+copies and that both that the copyright notice and this
+permission notice and warranty disclaimer appear in supporting
+documentation, and that the names of AT&T, Bell Laboratories,
+Lucent or Bellcore or any of their entities not be used in
+advertising or publicity pertaining to distribution of the
+software without specific, written prior permission.
+
+AT&T, Lucent and Bellcore disclaim all warranties with regard to
+this software, including all implied warranties of
+merchantability and fitness. In no event shall AT&T, Lucent or
+Bellcore be liable for any special, indirect or consequential
+damages or any damages whatsoever resulting from loss of use,
+data or profits, whether in an action of contract, negligence or
+other tortious action, arising out of or in connection with the
+use or performance of this software.
+EOF
+}