summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-02-14 17:33:53 +0100
committerhaawda2021-02-14 17:33:53 +0100
commitff504390b651644c554117def1e5e87ff8daa047 (patch)
tree0fa91755a5b6cadc2c00c0ad2114b56ab696e39f
parent7c7a211ce546d28da68c2f7777a65ee348195b8c (diff)
downloadaur-ff504390b651644c554117def1e5e87ff8daa047.tar.gz
adopted, updated, patch added
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD54
-rw-r--r--licenseinfo.patch21
3 files changed, 55 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b649fcb1661..c882ec0bd438 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = xephem
pkgdesc = The Serious Interactive Astronomical Software Ephemeris
- pkgver = 3.7.7
- pkgrel = 7
+ pkgver = 4.0.0
+ pkgrel = 1
url = http://www.clearskyinstitute.com/xephem/xephem.html
arch = i686
arch = x86_64
license = custom
depends = libxmu
depends = openmotif
- optdepends = perl
- optdepends = openssl
- source = http://www.clearskyinstitute.com/xephem/xephem-3.7.7.tgz
+ depends = perl
+ depends = openssl
+ source = http://www.clearskyinstitute.com/xephem/xephem-4.0.0.tgz
source = http://www.clearskyinstitute.com/xephem/contrib/xephem-3.7.7_openssl.patch
- md5sums = 27c67061a89085bf2b0d4e9deb758a79
- md5sums = 27b747ea7f31270547047117fceaa283
+ source = licenseinfo.patch
+ sha256sums = abc90e795b7076be3b5c2247162e1c853265b2d81c3399767ab569a5653f6301
+ sha256sums = 64365b25ac142ebcc9dc286a14f7b3c37aeb44ffcdc629d776b183099259b3f4
+ sha256sums = bb7bd33bbe3b1c87dfcebb752c85daef2821340952f1bfab16d49f2e9f107730
pkgname = xephem
diff --git a/PKGBUILD b/PKGBUILD
index 93c17363ca05..0787883146f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,40 @@
# Contributor: jmf <jmf [at] mesecons [dot] net>
pkgname=xephem
-pkgver=3.7.7
-pkgrel=7
+pkgver=4.0.0
+pkgrel=1
pkgdesc="The Serious Interactive Astronomical Software Ephemeris"
arch=('i686' 'x86_64')
url="http://www.clearskyinstitute.com/xephem/xephem.html"
-license=("custom")
-depends=(libxmu openmotif)
-optdepends=(perl openssl)
-makedepends=()
-source=(http://www.clearskyinstitute.com/xephem/$pkgname-$pkgver.tgz
-http://www.clearskyinstitute.com/xephem/contrib/xephem-3.7.7_openssl.patch)
-md5sums=('27c67061a89085bf2b0d4e9deb758a79'
-'27b747ea7f31270547047117fceaa283')
+license=('custom')
+depends=('libxmu' 'openmotif' 'perl' 'openssl')
+source=("http://www.clearskyinstitute.com/xephem/$pkgname-$pkgver.tgz"
+ "http://www.clearskyinstitute.com/xephem/contrib/xephem-3.7.7_openssl.patch"
+ licenseinfo.patch)
+sha256sums=('abc90e795b7076be3b5c2247162e1c853265b2d81c3399767ab569a5653f6301'
+ '64365b25ac142ebcc9dc286a14f7b3c37aeb44ffcdc629d776b183099259b3f4'
+ 'bb7bd33bbe3b1c87dfcebb752c85daef2821340952f1bfab16d49f2e9f107730')
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}/GUI/$pkgname
- chmod u+w Makefile net.h netmenu.c sunmenu.c ucac.c usno.c xephem.h
+ cd ${pkgname}-${pkgver}/GUI/$pkgname
+ chmod u+w Makefile net.h netmenu.c sunmenu.c ucac.c usno.c xephem.h \
+ auxil/mpcorb2edb.pl fallbacks.c webdbmenu.c
patch -p5 -i ../../../xephem-3.7.7_openssl.patch
- chmod u-w Makefile net.h netmenu.c sunmenu.c ucac.c usno.c xephem.h
+ cd ../..
+ patch -Np1 < "$srcdir"/licenseinfo.patch
}
build() {
- #cd ${srcdir}/$pkgname-$pkgver/
- cd ${srcdir}/${pkgname}-${pkgver}/GUI/$pkgname
- export MAKEFLAGS="-j1"
+ cd ${pkgname}-${pkgver}/GUI/$pkgname
+ export MAKEFLAGS+="-j1"
make MOTIF=/usr/lib/
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}/GUI/$pkgname
- mkdir -p ${pkgdir}/usr/bin
- cp ${srcdir}/${pkgname}-${pkgver}/GUI/$pkgname/xephem ${pkgdir}/usr/bin/
+ cd ${pkgname}-${pkgver}/GUI/$pkgname
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}/GUI/$pkgname/xephem "$pkgdir"/usr/bin/$pkgname
- mkdir -p ${pkgdir}/usr/share/$pkgname
+ install -d "$pkgdir"/usr/share/$pkgname
cp -R auxil ${pkgdir}/usr/share/$pkgname/
cp -R catalogs ${pkgdir}/usr/share/$pkgname/
@@ -46,15 +46,11 @@ package() {
cp -R help ${pkgdir}/usr/share/$pkgname/
cp -R lo ${pkgdir}/usr/share/$pkgname/
- mkdir -p ${pkgdir}/usr/share/man/man1/
- cp xephem.1 ${pkgdir}/usr/share/man/man1/
+ install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
-# mkdir -p ${pkgdir}/usr/lib/X11/app-defaults
-# echo "XEphem.ShareDir: /usr/share/xephem" > ${pkgdir}/usr/lib/X11/app-defaults/XEphem
- mkdir -p ${pkgdir}/usr/share/X11/app-defaults
- echo "XEphem.ShareDir: /usr/share/xephem" > ${pkgdir}/usr/share/X11/app-defaults/XEphem
+ install -d "$pkgdir"/usr/share/X11/app-defaults
+ echo "XEphem.ShareDir: /usr/share/xephem" > "$pkgdir"/usr/share/X11/app-defaults/XEphem
- mkdir -p ${pkgdir}/usr/share/licenses/$pkgname/
- cp ${srcdir}/${pkgname}-${pkgver}/Copyright ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
-
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/Copyright \
+ "$pkgdir"/usr/share/licenses/$pkgname/Copyright
}
diff --git a/licenseinfo.patch b/licenseinfo.patch
new file mode 100644
index 000000000000..e1b1a6b3ebe7
--- /dev/null
+++ b/licenseinfo.patch
@@ -0,0 +1,21 @@
+diff -Naur xephem-4.0.0.orig/GUI/xephem/versionmenu.c xephem-4.0.0.new/GUI/xephem/versionmenu.c
+--- xephem-4.0.0.orig/GUI/xephem/versionmenu.c 2021-02-07 21:09:00.878498540 +0100
++++ xephem-4.0.0.new/GUI/xephem/versionmenu.c 2021-02-14 17:16:46.126563543 +0100
+@@ -50,7 +50,7 @@
+ "Copyright (c) 2021 Elwood Charles Downey",
+ "",
+ "Permission is hereby granted, free of charge, to any person obtaining a copy",
+-"of this software and associated documentation files (the "Software"), to deal",
++"of this software and associated documentation files (the \"Software\"), to deal",
+ "in the Software without restriction, including without limitation the rights",
+ "to use, copy, modify, merge, publish, distribute, sublicense, and/or sell",
+ "copies of the Software, and to permit persons to whom the Software is",
+@@ -59,7 +59,7 @@
+ "The above copyright notice and this permission notice shall be included in all",
+ "copies or substantial portions of the Software.",
+ "",
+-"THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR",
++"THE SOFTWARE IS PROVIDED \"AS IS\", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR",
+ "IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,",
+ "FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE",
+ "AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER",