summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2016-01-18 20:36:25 -0500
committerbrent s2016-01-18 20:36:25 -0500
commitff909a97216de6ac47bc28df9cb1cb86b3e0a4e1 (patch)
tree4b17c3ac9b5d3ac59ea5c7f7895af18dcfd12726
parentddc42ea81b2c223777bf7c1539cd7fb9ba122a9e (diff)
downloadaur-ff909a97216de6ac47bc28df9cb1cb86b3e0a4e1.tar.gz
version bump
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--mondo-initrd.patch11
3 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3c1997bd5c8..5646a267a77b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Tue Jan 19 01:36:25 UTC 2016
pkgbase = mondo
pkgdesc = A disaster recovery solution to create backup media that can be used to redeploy the damaged system
- pkgver = 3.2.0
- pkgrel = 4
+ pkgver = 3.2.1
+ pkgrel = 1
url = http://www.mondorescue.org/
arch = i686
arch = x86_64
@@ -22,10 +24,8 @@ pkgbase = mondo
depends = slang
optdepends = lzop: File compressor using lzo lib
optdepends = lzo: A portable lossless data compression library
- source = ftp://ftp.mondorescue.org/src/mondo-3.2.0.tar.gz
- source = mondo-initrd.patch
- md5sums = 6f5ef27d940c90a858ce9b1888c23c2d
- md5sums = 29ba10f84bd587aa1b80f70f91be6b02
+ source = ftp://ftp.mondorescue.org/src/mondo-3.2.1.tar.gz
+ md5sums = 0625cb331e7312bab01fee7c418e108f
pkgname = mondo
diff --git a/PKGBUILD b/PKGBUILD
index 22841571599f..5c56b47bd8d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
# Maintainer: M.Carreira <arch@carreira.com.pt>
# Contributor: M.Carreira <arch@carreira.com.pt>
pkgname=mondo
-pkgver=3.2.0
-pkgrel=4
+pkgver=3.2.1
+pkgrel=1
pkgdesc="A disaster recovery solution to create backup media that can be used to redeploy the damaged system"
arch=('i686' 'x86_64')
url="http://www.mondorescue.org/"
@@ -12,15 +13,13 @@ depends=('mindi>=2.0.7' 'bzip2>=0.9' 'afio' 'cdrkit' 'binutils' 'libnewt>=0.50'
makedepends=('libnewt>=0.50' 'gcc' 'autoconf' 'automake' 'libtool')
optdepends=('lzop: File compressor using lzo lib'
'lzo: A portable lossless data compression library')
-source=("ftp://ftp.mondorescue.org/src/${pkgname}-${pkgver}.tar.gz"
- 'mondo-initrd.patch')
-md5sums=('6f5ef27d940c90a858ce9b1888c23c2d'
- '29ba10f84bd587aa1b80f70f91be6b02')
+source=("ftp://ftp.mondorescue.org/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0625cb331e7312bab01fee7c418e108f')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 < ../mondo-initrd.patch
+ sed -i -e 's/kernel26/linux/g' src/mondorestore/mondo-rstr-tools.c
./configure --prefix=/usr --sbindir=/usr/bin
make
make DESTDIR=${pkgdir} install
@@ -29,4 +28,3 @@ package() {
install -m 644 INSTALL COPYING README* TODO AUTHORS NEWS* docs/en/mondorescue-howto.html docs/en/mondorescue-howto.pdf ${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
}
-# vim:set ts=2 sw=2 et:
diff --git a/mondo-initrd.patch b/mondo-initrd.patch
deleted file mode 100644
index 1fbb84b93bb9..000000000000
--- a/mondo-initrd.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mondo-3.2.0/src/mondorestore/mondo-rstr-tools.c
-+++ mondo-3.2.0/src/mondorestore/mondo-rstr-tools-patch.c
-@@ -1246,7 +1246,7 @@
- ("You will now be able to re-generate your initrd.\nThis is especially useful if you changed of hardware configuration, cloned, made P2V, used multipath...\nDo you need to do it ?")) {
- log_msg(1,"Launching shell for manual initrd recreation");
- if (does_file_exist(MNT_RESTORING"/etc/arch-release")) {
-- popup_and_OK("You'll now be chrooted under your future / partition.\nEdit /etc/mkinitcpio.conf if needed and rebuild your initrd with the kernel preset name e.g.\nmkinitcpio -p kernel26\nThen type exit to finish.\n");
-+ popup_and_OK("You'll now be chrooted under your future / partition.\nEdit /etc/mkinitcpio.conf if needed and rebuild your initrd with the kernel preset name e.g.\nmkinitcpio -p linux\nThen type exit to finish.\n");
- } else {
- popup_and_OK("You'll now be chrooted under your future / partition.\nGo under /boot and rebuild your initrd with\nmkinitrd -f -v initrd-2.x.y.img 2.x.y e.g.\nThen type exit to finish.");
- }