summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2017-08-25 00:46:21 +0200
committerKokaKiwi2017-08-25 00:46:21 +0200
commitff93a1a01143fa144dffdeeb05c586e6341d2e8d (patch)
tree52a3e2d26d425db47079d495faa572fc7647f1a5
downloadaur-ff93a1a01143fa144dffdeeb05c586e6341d2e8d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD64
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d837f26a5a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ayojs-git
+ pkgdesc = It's pronounced like "IO"
+ pkgver = 8.4.0
+ pkgrel = 1
+ url = https://github.com/ayojs/ayo
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2
+ makedepends = procps-ng
+ depends = openssl-1.0
+ depends = zlib
+ depends = icu
+ depends = libuv
+ depends = http-parser
+ depends = c-ares
+ conflicts = nodejs
+ source = ayo::git://github.com/ayojs/ayo
+ sha512sums = SKIP
+
+pkgname = ayojs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6f73355a672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: KokaKiwi <kokakiwi+arch@kokakiwi.net>
+
+pkgname=ayojs-git
+pkgver=8.4.0
+pkgrel=1
+pkgdesc="It's pronounced like \"IO\""
+arch=('i686' 'x86_64')
+url='https://github.com/ayojs/ayo'
+license=('MIT')
+depends=('openssl-1.0' 'zlib' 'icu' 'libuv' 'http-parser' 'c-ares')
+conflicts=('nodejs')
+makedepends=('python2' 'procps-ng')
+source=("ayo::git://github.com/ayojs/ayo")
+sha512sums=('SKIP')
+
+prepare() {
+ cd ayo
+
+ msg 'Fixing for python2 name'
+ find -type f -exec sed \
+ -e 's_^#!/usr/bin/env python$_&2_' \
+ -e 's_^\(#!/usr/bin/python2\).[45]$_\1_' \
+ -e 's_^#!/usr/bin/python$_&2_' \
+ -e 's_^\( *exec \+\)python\( \+.*\)$_\1python2\2_'\
+ -e 's_^\(.*\)python\( \+-c \+.*\)$_\1python2\2_'\
+ -e "s_'python'_'python2'_" -i {} \;
+ find test/ -type f -exec sed 's_python _python2 _' -i {} \;
+
+ export PKG_CONFIG_PATH="/usr/lib/openssl-1.0/pkgconfig"
+ export PYTHON="python2"
+
+ ./configure \
+ --prefix=/usr \
+ --with-intl=system-icu \
+ --without-npm \
+ --shared-openssl \
+ --shared-zlib \
+ --shared-libuv \
+ --shared-http-parser \
+ --shared-cares
+}
+
+build() {
+ cd ayo
+
+ make
+}
+
+check() {
+ cd ayo
+
+ make test || warning "Tests failed"
+}
+
+package() {
+ cd ayo
+
+ make install DESTDIR="$pkgdir"
+
+ install -D -m644 LICENSE \
+ "$pkgdir"/usr/share/licenses/ayojs/LICENSE
+}
+
+# vim: set ts=4 sw=4 et: