summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Hinssen2018-03-23 15:35:18 +0100
committerNicola Hinssen2018-03-23 15:35:18 +0100
commitffa7f5931e3bed8162809f2b9fefbeaee3f1254c (patch)
treee832b78d550c3f9f9756bdba7702abb61a39c668
parent9eef7ab3456de27f53c103e650753f4d591c5d33 (diff)
downloadaur-ffa7f5931e3bed8162809f2b9fefbeaee3f1254c.tar.gz
More changes
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--ombi.install16
-rw-r--r--ombi.service2
-rw-r--r--ombi.tmpfiles3
5 files changed, 31 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 563a8a6909b4..23efb6639d40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ombi-dev
pkgdesc = Ombi V3 Develop branch. Gives Plex or Emby users the ability to request content by themselves
pkgver = 3.0.3072
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tidusjar/Ombi
install = ombi.install
- arch = any
+ arch = x86_64
license = GPL2
- makedepends = tar
+ makedepends = bsdtar
depends = libunwind
depends = openssl-1.0
optdepends = sonarr: Automated TV show downloads
@@ -20,15 +20,17 @@ pkgbase = ombi-dev
conflicts = ombi
replaces = plexrequests
replaces = ombi-beta
- noextract = ombi-dev.tar.gz
+ noextract = ombi-dev-3.0.3072.tar.gz
options = staticlibs
backup = opt/Ombi/Ombi.sqlite
- source = ombi-dev.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz?branch=develop
+ source = ombi-dev-3.0.3072.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz?branch=develop
source = ombi.service
source = ombi.sysusers
+ source = ombi.tmpfiles
sha256sums = SKIP
sha256sums = 79f4860eaf9d00d3739c6d9fc5e9625ea68dc329bb1cbddae5b51ae4faaae20f
sha256sums = 6efc381990e1113737686d4f61795095fa8edbc176daa877fd755f1ddb3a40fa
+ sha256sums = afb971692d313d988096cb4447033f8ca2234016ccc2b3590afd5cbcb36a8e56
pkgname = ombi-dev
diff --git a/PKGBUILD b/PKGBUILD
index 14ae719a14bc..a63fc550d427 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=ombi-dev
pkgver=3.0.3072
-pkgrel=2
+pkgrel=3
pkgdesc="Ombi V3 Develop branch. Gives Plex or Emby users the ability to request content by themselves"
-arch=('any')
+arch=('x86_64')
url='https://github.com/tidusjar/Ombi'
license=('GPL2')
depends=('libunwind' 'openssl-1.0')
-makedepends=('tar')
+makedepends=('bsdtar')
optdepends=('sonarr: Automated TV show downloads'
'sickrage: Automated TV show downloads'
'radarr: Automated movie downloads'
@@ -25,13 +25,17 @@ conflicts=('ombi')
options=('staticlibs')
backup=('opt/Ombi/Ombi.sqlite')
install='ombi.install'
-noextract=("${pkgname}.tar.gz")
-source=("${pkgname}.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz?branch=develop"
+source=("${pkgname}-${pkgver}.tar.gz::https://ci.appveyor.com/api/projects/tidusjar/requestplex/artifacts/linux.tar.gz?branch=develop"
'ombi.service'
- 'ombi.sysusers')
+ 'ombi.sysusers'
+ 'ombi.tmpfiles')
+
+noextract=("${pkgname}-${pkgver}.tar.gz")
+
sha256sums=('SKIP'
'79f4860eaf9d00d3739c6d9fc5e9625ea68dc329bb1cbddae5b51ae4faaae20f'
- '6efc381990e1113737686d4f61795095fa8edbc176daa877fd755f1ddb3a40fa')
+ '6efc381990e1113737686d4f61795095fa8edbc176daa877fd755f1ddb3a40fa'
+ 'afb971692d313d988096cb4447033f8ca2234016ccc2b3590afd5cbcb36a8e56')
pkgver() {
curl -s https://ci.appveyor.com/api/projects/tidusjar/requestplex/branch/develop | grep -Pom 1 '"version":"\K[^"]*'
@@ -39,7 +43,7 @@ pkgver() {
prepare() {
mkdir -p "${srcdir}/ombi"
- tar -xzf "${pkgname}.tar.gz" -C "${srcdir}/ombi"
+ bsdtar -x -C "${srcdir}/ombi" -f "${pkgname}-${pkgver}.tar.gz"
}
package() {
@@ -51,4 +55,5 @@ package() {
install -Dm644 "${srcdir}/ombi.service" "${pkgdir}/usr/lib/systemd/system/ombi.service"
install -Dm644 "${srcdir}/ombi.sysusers" "${pkgdir}/usr/lib/sysusers.d/ombi.conf"
+ install -Dm644 "${srcdir}/ombi.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/ombi.conf"
}
diff --git a/ombi.install b/ombi.install
index b6f77d09d0a9..24dfdc4eee5a 100644
--- a/ombi.install
+++ b/ombi.install
@@ -1,14 +1,12 @@
-post_install() {
- systemd-sysusers ombi.conf
- chown -R ombi:ombi /opt/Ombi
+pre_upgrade() {
+ systemctl stop ombi.service
}
post_upgrade() {
- chown -R ombi:ombi /opt/Ombi
- systemctl daemon-reload
-}
+ if [ -f /opt/Ombi/Ombi.sqlite ]; then
+ mv /opt/Ombi/Ombi.sqlite /var/lib/ombi/Ombi.sqlite
+ fi
-post_remove() {
- systemctl stop ombi.service
- true
+ systemctl daemon-reload
+ systemctl start ombi.service
}
diff --git a/ombi.service b/ombi.service
index 07b7fdee5f1f..6a393e3113e2 100644
--- a/ombi.service
+++ b/ombi.service
@@ -7,7 +7,7 @@ User=ombi
Group=ombi
WorkingDirectory=/opt/Ombi
Type=simple
-ExecStart=/opt/Ombi/Ombi
+ExecStart=/opt/Ombi/Ombi --storage /var/lib/ombi
TimeoutStopSec=30
Restart=always
diff --git a/ombi.tmpfiles b/ombi.tmpfiles
new file mode 100644
index 000000000000..8a556814c4bf
--- /dev/null
+++ b/ombi.tmpfiles
@@ -0,0 +1,3 @@
+d /var/lib/ombi 0755 ombi ombi
+Z /var/lib/ombi - ombi ombi
+Z /opt/Ombi - ombi ombi