summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Sałaban2016-11-06 01:42:01 +0100
committerMichał Sałaban2016-11-06 01:42:01 +0100
commitffb9f4c6accd8e9afb85dd1be5e266296ffb9ed4 (patch)
treeac5f466102de2088e9bcfe2796fc527efce4ad43
downloadaur-ffb9f4c6accd8e9afb85dd1be5e266296ffb9ed4.tar.gz
Initial revision
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3c344d672bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-diff_match_patch
+ pkgdesc = The Diff Match and Patch libraries offer robust algorithms to perform the operations required for synchronizing plain text
+ pkgver = 20121119
+ pkgrel = 1
+ url = http://code.google.com/p/google-diff-match-patch/
+ arch = any
+ license = Apache
+ depends = python
+ source = https://pypi.python.org/packages/22/82/46eaeab04805b4fac17630b59f30c4f2c8860988bcefd730ff4f1992908b/diff-match-patch-20121119.tar.gz
+ md5sums = 08e02cad82dda942b09ee248772fe143
+
+pkgname = python-diff_match_patch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a258010dfde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Michał Sałaban <michal@salaban.info>
+
+pkgname=python-diff_match_patch
+pkgver=20121119
+pkgrel=1
+pkgdesc='The Diff Match and Patch libraries offer robust algorithms to perform the operations required for synchronizing plain text'
+arch=('any')
+url='http://code.google.com/p/google-diff-match-patch/'
+license=('Apache')
+depends=('python')
+source=("https://pypi.python.org/packages/22/82/46eaeab04805b4fac17630b59f30c4f2c8860988bcefd730ff4f1992908b/diff-match-patch-$pkgver.tar.gz")
+md5sums=('08e02cad82dda942b09ee248772fe143')
+
+build() {
+ cd "$srcdir/diff-match-patch-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "$srcdir/diff-match-patch-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/"
+}