summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2022-01-25 13:48:03 -0300
committerRodrigo Bezerra2022-01-25 13:48:03 -0300
commitffbf19823146dfe309e02a54de0f6084f7ba65d4 (patch)
tree27c3d64fef4e155eb51126499e81f39283683183
parent1271d2687d1361099622d20354595b478d25f56f (diff)
downloadaur-ffbf19823146dfe309e02a54de0f6084f7ba65d4.tar.gz
Update to version 1.4.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f698d6c3fc4..80b5010f3d6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-gupnp
pkgdesc = An object-oriented UPNP framework (32-bit)
- pkgver = 1.4.1
+ pkgver = 1.4.3
pkgrel = 1
url = https://wiki.gnome.org/Projects/GUPnP
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = lib32-gupnp
makedepends = vala
depends = lib32-gssdp
depends = gupnp
- source = git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=21cf45befcdfbda8882ff4805f9e791270e28274
+ source = git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=1e752b11dc51673c71c70bbf6deb34c96e3abd19
sha256sums = SKIP
pkgname = lib32-gupnp
diff --git a/PKGBUILD b/PKGBUILD
index 7e08235c67f6..63728a439937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
-_basename=gupnp
pkgname=lib32-gupnp
-pkgver=1.4.1
+pkgver=1.4.3
pkgrel=1
pkgdesc="An object-oriented UPNP framework (32-bit)"
arch=(x86_64)
@@ -10,14 +9,21 @@ url="https://wiki.gnome.org/Projects/GUPnP"
license=(LGPL)
depends=(lib32-gssdp gupnp)
makedepends=(git gobject-introspection meson vala)
-_commit=21cf45befcdfbda8882ff4805f9e791270e28274 # tags/gupnp-1.4.1^0
+_commit=1e752b11dc51673c71c70bbf6deb34c96e3abd19 # tags/gupnp-1.4.3^0
source=("git+https://gitlab.gnome.org/GNOME/gupnp.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd gupnp
- git describe --tags | sed 's/^gupnp-//;s/-/+/g'
+ git describe --tags | sed 's/^gupnp-//;s/[^-]*-g/r&/;s/-/+/g'
+}
+
+prepare() {
+ cd gupnp
+
+ # Unbreak man page build
+ git revert -n 8795626a07963a91400773cfe04d4f2f1c37ff14
}
build() {