summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-08-23 20:07:49 +0200
committerMichal Wojdyla2021-08-23 20:07:49 +0200
commitffc2901ec87aec507eed13d4c9d98b7852826e1c (patch)
treeac26aa4249c03497a1901a4292be85d9e3de3c2b
parent9183a899be32336fa3f5d81294684564fbbaf2a8 (diff)
downloadaur-ffc2901ec87aec507eed13d4c9d98b7852826e1c.tar.gz
update
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3862f307c4a8..542a679aea33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,27 @@
pkgbase = i3pystatus-git
pkgdesc = i3status replacement written in python for the i3 window manager
- pkgver = 3.1.r175.g7c82053
+ pkgver = 3.35.r370.gac71437
pkgrel = 1
url = https://github.com/enkore/i3pystatus.git
arch = i686
arch = x86_64
- license = mit
+ license = MIT
makedepends = git
makedepends = python-setuptools
depends = python
- optdepends = python-netifaces: network
- optdepends = python-colour: network
- optdepends = basiciw-git: wireless network
- optdepends = python-dbus: now-playing, thunderbird
- optdepends = python-gobject: thunderbird
- optdepends = python-gobject2: thunderbird
- optdepends = python-beautifulsoup4: parcel
- optdepends = python-cssselect: parcel,
- optdepends = python-lxml: parcel,
- optdepends = python-pywapi: weather
- optdepends = python-pyalsaaudio: ALSA
- optdepends = python-psutil: memory
+ optdepends = python-pyalsaaudio: For the alsa module.,
+ optdepends = python-dbus: For the thunderbird or now_playing modules.,
+ optdepends = python-psutil: For the mem, membar or network_traffic modules.,
+ optdepends = python-netifaces: For the network or wireless modules.,
+ optdepends = python-beautifulsoup4: For the parcel module.,
+ optdepends = python-cssselect: For the parcel module.,
+ optdepends = python-lxml: For the parcel module.,
+ optdepends = python-pywapi: For the weather module.,
+ optdepends = python-basiciw: For the wireless module.
+ optdepends = python-colour: For the pulseaudio module.
provides = i3pystatus
conflicts = i3pystatus
source = git+https://github.com/enkore/i3pystatus.git
md5sums = SKIP
pkgname = i3pystatus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 884558e352e1..30f499e95549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
-# Maintainer: Jan Oliver Oelerich <janoliver@oelerich.org>
+# Contributor: Jan Oliver Oelerich <janoliver@oelerich.org>
pkgname=i3pystatus-git
pkgdesc="i3status replacement written in python for the i3 window manager"
-pkgver=3.1.r175.g7c82053
+pkgver=3.35.r370.gac71437
pkgrel=1
conflicts=('i3pystatus')
provides=('i3pystatus')
arch=('i686' 'x86_64')
-license=('mit')
+license=('MIT')
depends=('python')
-optdepends=(
- 'python-netifaces: network'
- 'python-colour: network'
- 'basiciw-git: wireless network'
- 'python-dbus: now-playing, thunderbird'
- 'python-gobject: thunderbird'
- 'python-gobject2: thunderbird'
- 'python-beautifulsoup4: parcel'
- 'python-cssselect: parcel',
- 'python-lxml: parcel',
- 'python-pywapi: weather'
- 'python-pyalsaaudio: ALSA'
- 'python-psutil: memory')
+optdepends=('python-pyalsaaudio: For the alsa module.',
+ 'python-dbus: For the thunderbird or now_playing modules.',
+ 'python-psutil: For the mem, membar or network_traffic modules.',
+ 'python-netifaces: For the network or wireless modules.',
+ 'python-beautifulsoup4: For the parcel module.',
+ 'python-cssselect: For the parcel module.',
+ 'python-lxml: For the parcel module.',
+ 'python-pywapi: For the weather module.',
+ 'python-basiciw: For the wireless module.'
+ 'python-colour: For the pulseaudio module.')
makedepends=('git' 'python-setuptools')
url="https://github.com/enkore/i3pystatus.git"
source=('git+https://github.com/enkore/i3pystatus.git')
@@ -34,10 +31,11 @@ pkgver() {
}
build() {
- :
+ cd "$srcdir/$_gitname"
+ python setup.py build
}
package() {
cd "$srcdir/$_gitname"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1
}