summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Birks2019-05-30 00:53:41 -0400
committerDavid Birks2019-05-30 00:53:41 -0400
commitffebd05b5fe26256419f7062c6c9cc06f4dbaa5b (patch)
tree20d0e519160d7970d7b6ad840d3d71740a3dad79
downloadaur-ffebd05b5fe26256419f7062c6c9cc06f4dbaa5b.tar.gz
Add 1.5.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f65621087e0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kube-fzf
+ pkgdesc = Command-line fuzzy searching of Kubernetes pods
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/thecasualcoder/kube-fzf
+ arch = any
+ license = MIT
+ depends = fzf
+ source = kube-fzf-1.5.0::https://github.com/thecasualcoder/kube-fzf/archive/v1.5.0.tar.gz
+ sha512sums = 36fcc9be40a3666581fe06ebf6ce5ea99732d801cf6e632253ff4ac02025909a34612a920fcb6d0960da80a4ff443cc53a0fb84f16d00d534f43149785ecc182
+
+pkgname = kube-fzf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a102635e68c0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.pkg.tar*
+pkg/
+src/
+kube-fzf*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6becb9f5a0c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: David Birks <david@tellus.space>
+
+pkgname=kube-fzf
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Command-line fuzzy searching of Kubernetes pods'
+arch=(any)
+url='https://github.com/thecasualcoder/kube-fzf'
+license=(MIT)
+depends=('fzf')
+source=("$pkgname-$pkgver::https://github.com/thecasualcoder/kube-fzf/archive/v$pkgver.tar.gz")
+sha512sums=('36fcc9be40a3666581fe06ebf6ce5ea99732d801cf6e632253ff4ac02025909a34612a920fcb6d0960da80a4ff443cc53a0fb84f16d00d534f43149785ecc182')
+
+package() {
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/findpod" "$pkgdir/usr/bin/findpod"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/execpod" "$pkgdir/usr/bin/execpod"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/tailpod" "$pkgdir/usr/bin/tailpod"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/describepod" "$pkgdir/usr/bin/describepod"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/pfpod" "$pkgdir/usr/bin/pfpod"
+ install -Dm 755 "$srcdir/$pkgname-$pkgver/kube-fzf.sh" "$pkgdir/usr/bin/kube-fzf.sh"
+}