summarylogtreecommitdiffstats
path: root/CMakeLists-signal.patch
diff options
context:
space:
mode:
authoracxz2019-06-12 15:18:38 -0400
committeracxz2019-06-12 15:18:38 -0400
commit978d8f27b0333f28fb78f4d88bdb7d1474f5144b (patch)
treeaca4674e945450f78d567715044ac8d3c7c7721b /CMakeLists-signal.patch
parent0d4eadb96c1459996ae42ac041310a468642b38c (diff)
downloadaur-978d8f27b0333f28fb78f4d88bdb7d1474f5144b.tar.gz
Fixed building without signals and changed to official source
Diffstat (limited to 'CMakeLists-signal.patch')
-rw-r--r--CMakeLists-signal.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists-signal.patch b/CMakeLists-signal.patch
new file mode 100644
index 000000000000..756b2b678263
--- /dev/null
+++ b/CMakeLists-signal.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2019-06-12 15:05:37.559918718 -0400
++++ CMakeLists.txt 2019-06-12 15:06:14.116583763 -0400
+@@ -9,7 +9,7 @@
+ laser_geometry pluginlib angles)
+
+ find_package(catkin REQUIRED COMPONENTS ${THIS_PACKAGE_ROS_DEPS})
+-find_package(Boost REQUIRED COMPONENTS system signals)
++find_package(Boost REQUIRED COMPONENTS system)
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+
+ ##############################################################################