summarylogtreecommitdiffstats
path: root/CMakeLists.inj
diff options
context:
space:
mode:
authorDmitry Porunov2019-11-11 04:39:37 +0400
committerDmitry Porunov2019-11-11 04:39:37 +0400
commita93d8b49fc77c1086164cd349fede66e08003f9d (patch)
tree9fb49f97fdf1fc2a2b7222fd42e1ab1fe4577454 /CMakeLists.inj
parent9abda47ab98590c8e869e52abb24d19ab1d1df36 (diff)
downloadaur-a93d8b49fc77c1086164cd349fede66e08003f9d.tar.gz
Release k1.1
Diffstat (limited to 'CMakeLists.inj')
-rw-r--r--CMakeLists.inj20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.inj b/CMakeLists.inj
new file mode 100644
index 000000000000..e6cfed4cf6dd
--- /dev/null
+++ b/CMakeLists.inj
@@ -0,0 +1,20 @@
+# The text will be put into the appropriate CMakeLists by the PKGBUILD
+
+# Avoid rpath compiler parameter
+set_target_properties(Telegram PROPERTIES SKIP_BUILD_RPATH TRUE)
+
+# This makes up for patch of gyp utility, supporting precompiled headers. If
+# Telegram/Patches/gyp.diff file will be changed in future, please check these
+# lines.
+include(../../Telegram/gyp/PrecompiledHeader.cmake)
+add_precompiled_header(Telegram ../../Telegram/SourceFiles/stdafx.h)
+add_precompiled_header(lib_base ../../Telegram/SourceFiles/base/base_pch.h)
+add_precompiled_header(lib_export ../../Telegram/SourceFiles/export/export_pch.h)
+add_precompiled_header(lib_storage ../../Telegram/SourceFiles/storage/storage_pch.h)
+add_precompiled_header(lib_mtproto ../../Telegram/SourceFiles/mtproto/mtp_pch.h)
+add_precompiled_header(lib_ui ../../Telegram/SourceFiles/ui/ui_pch.h)
+
+# You can discover new PCHs using this link:
+# https://github.com/telegramdesktop/tdesktop/search?q=pch_header&unscoped_q=pch_header
+
+# vim: ft=cmake