summarylogtreecommitdiffstats
path: root/CMakeLists.inj
diff options
context:
space:
mode:
authorHexchain Tong2017-02-04 12:17:38 +0800
committerHexchain Tong2017-02-04 12:17:38 +0800
commita431a190966143900ebbad803cb6cc6e5895f2c6 (patch)
tree0ddc3c680901ac62108002236f3dd275aed386ce /CMakeLists.inj
downloadaur-a431a190966143900ebbad803cb6cc6e5895f2c6.tar.gz
newpkg
Diffstat (limited to 'CMakeLists.inj')
-rw-r--r--CMakeLists.inj14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.inj b/CMakeLists.inj
new file mode 100644
index 000000000000..e039cb1585af
--- /dev/null
+++ b/CMakeLists.inj
@@ -0,0 +1,14 @@
+# ------------- debian/CMakeLists.inj begin -------------
+# The text will be putted into the appropriate CMakeLists by debian/rules script
+
+# Avoid rpath compiler parameter
+set_target_properties(Telegram PROPERTIES SKIP_BUILD_RPATH TRUE)
+
+# This makes up for patch of gyp utility, supporting precompiled headers. If
+# Telegram/Patches/gyp.diff file will be changed in future, please check these
+# lines.
+include(../../Telegram/gyp/PrecompiledHeader.cmake)
+add_precompiled_header(Telegram ../../Telegram/SourceFiles/stdafx.h)
+
+# vim: ft=cmake
+# -------------- debian/CMakeLists.inj end --------------