summarylogtreecommitdiffstats
path: root/CMakeLists.patch
diff options
context:
space:
mode:
authoracxz2020-05-21 22:29:47 -0400
committeracxz2020-05-21 22:29:47 -0400
commitfcbcecb3d334385b98a8ae6d30154e5673330046 (patch)
treeb9ee54cfcd068ca0d7a12e0771f314879a39a4e8 /CMakeLists.patch
parent81606c8a9401bc00b18e5aaeb9ef0b29d4626573 (diff)
downloadaur-fcbcecb3d334385b98a8ae6d30154e5673330046.tar.gz
updpkg airsim
Diffstat (limited to 'CMakeLists.patch')
-rw-r--r--CMakeLists.patch67
1 files changed, 0 insertions, 67 deletions
diff --git a/CMakeLists.patch b/CMakeLists.patch
deleted file mode 100644
index 36ec2768a7e1..000000000000
--- a/CMakeLists.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -ruN AirSim-v.1.2.2/cmake/AirLib/CMakeLists.txt airsim-patch/cmake/AirLib/CMakeLists.txt
---- AirSim-v.1.2.2/cmake/AirLib/CMakeLists.txt 2020-01-26 18:40:04.078962761 -0500
-+++ airsim-patch/cmake/AirLib/CMakeLists.txt 2020-01-26 18:39:45.758814458 -0500
-@@ -1,7 +1,7 @@
- cmake_minimum_required(VERSION 3.5.0)
- project(AirLib)
-
--LIST(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/../cmake-modules")
-+LIST(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/../cmake-modules")
- INCLUDE("${CMAKE_CURRENT_LIST_DIR}/../cmake-modules/CommonSetup.cmake")
- CommonSetup()
-
-@@ -14,7 +14,7 @@
- ${RPC_LIB_INCLUDES}
- )
-
--file(GLOB_RECURSE ${PROJECT_NAME}_sources
-+file(GLOB_RECURSE ${PROJECT_NAME}_sources
- ${AIRSIM_ROOT}/${PROJECT_NAME}/src/api/*.cpp
- ${AIRSIM_ROOT}/${PROJECT_NAME}/src/common/common_utils/*.cpp
- ${AIRSIM_ROOT}/${PROJECT_NAME}/src/safety/*.cpp
-@@ -28,6 +28,7 @@
- CommonTargetLink()
- target_link_libraries(${PROJECT_NAME} ${RPC_LIB})
- target_link_libraries(${PROJECT_NAME} MavLinkCom)
-+target_link_libraries(${PROJECT_NAME} Eigen3::Eigen)
-
- #string(SUBSTRING ${CMAKE_STATIC_LINKER_FLAGS} 9 -1 "BUILD_PLATFORM")
- #find_package(Threads REQUIRED)
-diff -ruN AirSim-v.1.2.2/cmake/CMakeLists.txt airsim-patch/cmake/CMakeLists.txt
---- AirSim-v.1.2.2/cmake/CMakeLists.txt 2020-01-26 18:40:04.078962761 -0500
-+++ airsim-patch/cmake/CMakeLists.txt 2020-01-26 18:39:45.758814458 -0500
-@@ -1,10 +1,10 @@
- cmake_minimum_required(VERSION 3.5.0)
- project(AirSim)
-
--add_subdirectory("rpclib_wrapper")
-+#add_subdirectory("rpclib_wrapper")
- add_subdirectory("AirLib")
- add_subdirectory("MavLinkCom")
--add_subdirectory("AirLibUnitTests")
-+#add_subdirectory("AirLibUnitTests")
- add_subdirectory("HelloDrone")
- add_subdirectory("HelloCar")
- add_subdirectory("DroneShell")
-diff -ruN AirSim-v.1.2.2/cmake/cmake-modules/CommonSetup.cmake airsim-patch/cmake/cmake-modules/CommonSetup.cmake
---- AirSim-v.1.2.2/cmake/cmake-modules/CommonSetup.cmake 2020-01-26 18:40:04.078962761 -0500
-+++ airsim-patch/cmake/cmake-modules/CommonSetup.cmake 2020-01-26 18:39:45.762147818 -0500
-@@ -6,7 +6,9 @@
- endmacro(CommonTargetLink)
-
- macro(IncludeEigen)
-- include_directories(${AIRSIM_ROOT}/AirLib/deps/eigen3)
-+ #include_directories(${AIRSIM_ROOT}/AirLib/deps/eigen3)
-+ find_package(Eigen3 REQUIRED)
-+ include_directories(${Eigen_INCLUDE_DIRS})
- endmacro(IncludeEigen)
-
- macro(AddExecutableSource)
-@@ -66,6 +68,7 @@
- -Wold-style-cast -Woverloaded-virtual -Wredundant-decls -Wshadow -Wstrict-overflow=5 -Wswitch-default -Wundef \
- -Wno-variadic-macros -Wno-parentheses -Wno-unused-function -Wno-unused -Wno-documentation -fdiagnostics-show-option \
- -pthread \
-+ -fpermissive \
- ${RPC_LIB_DEFINES} ${CMAKE_CXX_FLAGS}")
-
- if (${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")