summarylogtreecommitdiffstats
path: root/CMakeLists.patch
diff options
context:
space:
mode:
authorarchshift2015-12-20 00:10:22 -0800
committerarchshift2015-12-20 00:12:15 -0800
commit26534d68fd17612dcb4693e3ef1b628c6d19caf8 (patch)
tree225fe149916c33d56f2fb2720086e8a5fc46c8f4 /CMakeLists.patch
downloadaur-26534d68fd17612dcb4693e3ef1b628c6d19caf8.tar.gz
Initial commit
Diffstat (limited to 'CMakeLists.patch')
-rw-r--r--CMakeLists.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..fa43ffb3e981
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,16 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1bc6e2b..57e2f81 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,8 +9,7 @@ project (${project_name})
+
+ add_subdirectory("src")
+
+-find_program(XDG_DESKTOP_MENU_EXECUTABLE xdg-desktop-menu)
+-if(XDG_DESKTOP_MENU_EXECUTABLE)
+- file(MAKE_DIRECTORY "/usr/share/desktop-directories") #Workaround for https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=730621
+- install(CODE "execute_process(COMMAND ${XDG_DESKTOP_MENU_EXECUTABLE} install --novendor share/juci.desktop)")
++if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|OpenBSD|NetBSD")
++ install(FILES "${CMAKE_SOURCE_DIR}/share/juci.desktop"
++ DESTINATION "${CMAKE_INSTALL_PREFIX}/share/applications")
+ endif()