summarylogtreecommitdiffstats
path: root/CMakeLists.patch
diff options
context:
space:
mode:
authorFelix Exner2020-12-04 11:42:13 +0100
committerFelix Exner2020-12-04 12:52:25 +0100
commit261da0c1dbaea82e555dd250c0bc002ae57eac37 (patch)
tree6f4988f48795ddc83f41a7af55c8083a66d4b977 /CMakeLists.patch
parentdbc9d256eb36ec4ef55d41e16c68f4d5d874c558 (diff)
downloadaur-261da0c1dbaea82e555dd250c0bc002ae57eac37.tar.gz
Added patch for c++14 requirement of pcl
Diffstat (limited to 'CMakeLists.patch')
-rw-r--r--CMakeLists.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.patch b/CMakeLists.patch
new file mode 100644
index 000000000000..2f862f992809
--- /dev/null
+++ b/CMakeLists.patch
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.old 2020-06-02 22:37:39.983352068 +0200
++++ CMakeLists.txt 2020-06-02 22:37:49.753352117 +0200
+@@ -15,6 +15,7 @@
+ cmake_minimum_required(VERSION 2.8.12) # Ships with Ubuntu 14.04 (Trusty)
+
+ project(cartographer_ros)
++add_compile_options(-std=c++14)
+
+ set(PACKAGE_DEPENDENCIES
+ cartographer_ros_msgs