summarylogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJP-Ellis2022-04-09 19:50:38 +1000
committerGitHub2022-04-09 11:50:38 +0200
commit1f0b3698a0cd6ffe5fa758074591d615d9b6475b (patch)
tree4811163a6929f4a1ed0a9b600f1a75623ea36157 /CMakeLists.txt
parente6268d09f9037a966644d3dd634c8f763e7d8a6b (diff)
downloadaur-1f0b3698a0cd6ffe5fa758074591d615d9b6475b.tar.gz
upgpkg: rocm-core 5.1.0-1 (#730)
* upgpkg: rocm-core 5.1.0-1 Signed-off-by: JP-Ellis <josh@jpellis.me> * Use upstream deb Use the upstream deb file to obtain the information and header files. The included source file is based on the disassembly of the binary as no source could be found. Partially fixes #739. Signed-off-by: JP-Ellis <josh@jpellis.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..cd270702b8c5
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.23)
+project(rocm-core)
+add_library(rocm-core SHARED rocm_version.c)
+set_target_properties(rocm-core PROPERTIES VERSION "1.0.${ROCM_VERSION}")
+find_path(ROCM_HEADER_DIR rocm_version.h)
+target_include_directories(rocm-core PUBLIC ${ROCM_HEADER_DIR})
+install(TARGETS rocm-core LIBRARY DESTINATION lib)