summarylogtreecommitdiffstats
path: root/Cargo.toml.patch
diff options
context:
space:
mode:
authorgéballin2019-08-01 11:11:02 +0200
committergéballin2019-08-01 11:11:02 +0200
commit3e37dabcbfb89c52a0b6c90b81724f2c68ccfbab (patch)
tree1f16207e882fd6f6be00f7ea63fab92d51e68986 /Cargo.toml.patch
parentd7614f4ea32e612d3172fdd6c6c4b34f816ef87c (diff)
downloadaur-systemd-manager.tar.gz
Patching the Cargo.toml and analyzer.rs files to compile with new version avec GTK.
Diffstat (limited to 'Cargo.toml.patch')
-rw-r--r--Cargo.toml.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/Cargo.toml.patch b/Cargo.toml.patch
new file mode 100644
index 000000000000..820a3526e2c3
--- /dev/null
+++ b/Cargo.toml.patch
@@ -0,0 +1,37 @@
+3c3
+< version = "1.0.0"
+---
+> version = "1.0.2"
+11,28d10
+< [package.metadata.deb]
+< maintainer = "Michael Aaron Murphy <mmstickman@gmail.com>"
+< copyright = "2015-2016, Michael Aaron Murphy <mmstickman@gmail.com>"
+< license_file = ["LICENSE", "3"]
+< depends = "$auto"
+< extended_description = """\
+< Written safely in Rust, this systemd manager provides a simple GTK3 GUI interface \
+< that allows you to enable/disable/start/stop services, monitor service logs, and \
+< edit unit files without ever using the terminal."""
+< section = "admin"
+< priority = "optional"
+< assets = [
+< ["assets/org.freedesktop.policykit.systemd-manager.policy", "usr/share/polkit-1/actions/", "644"],
+< ["assets/systemd-manager.desktop", "usr/share/applications/", "644"],
+< ["assets/systemd-manager-pkexec", "usr/bin/", "755"],
+< ["target/release/systemd-manager", "usr/bin/", "755"]
+< ]
+<
+30,37c12,15
+< dbus = "0.3.4"
+< gtk = { version = "0.1.0", features = ["v3_16"] }
+< gdk = { version = "0.5.0" }
+< quickersort = "2.0.1"
+<
+< [profile.release]
+< opt-level = 3
+< lto = true
+---
+> dbus = "0.5"
+> gtk = { version = "0.2.0", features = ["v3_16"] }
+> gdk = { version = "0.6" }
+> quickersort = "2.0"