aboutsummarylogtreecommitdiffstats
path: root/Dockerfile
diff options
context:
space:
mode:
authorRandy Fay2020-06-02 19:41:23 -0600
committerRandy Fay2020-06-02 19:41:23 -0600
commit748b41c5ad92e024fe69d0388f0d64703f3f60ed (patch)
treef3976542653742615b91c0442d5c6dbedff75caf /Dockerfile
parent087d27d4563a8a7d12e289a75b6559f383f61c91 (diff)
downloadaur-748b41c5ad92e024fe69d0388f0d64703f3f60ed.tar.gz
Bump to v1.15-alpha3
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile13
1 files changed, 7 insertions, 6 deletions
diff --git a/Dockerfile b/Dockerfile
index e7874cf3bb6c..2b7d5a048238 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -1,9 +1,10 @@
-# Build this with `docker build -t arch .`
-# Then run it with
-# docker run -it --rm --mount type=bind,source=$(pwd),target=/tmp/ddev-bin --workdir=/tmp/ddev-bin arch
-# makepkg --printsrcinfo > .SRCINFO
-# makepkg -s
+# - Edit PKGBUILD to change the version and hash
+# - Build this with `docker build -t arch .`
+# - Then run it with
+# docker run -it --rm --mount type=bind,source=$(pwd),target=/tmp/ddev-bin --workdir=/tmp/ddev-bin arch bash -c "makepkg --printsrcinfo > .SRCINFO && makepkg -s"
+# Then `git add -u` and commit and push
FROM archlinux:latest
RUN echo | pacman -Sy sudo binutils fakeroot docker docker-compose
RUN useradd builder
-CMD bash -c "su builder"
+USER builder
+CMD bash