summarylogtreecommitdiffstats
path: root/MUMPS-shared-seq.patch
diff options
context:
space:
mode:
authorheavysink2020-05-16 03:29:14 -0400
committerheavysink2020-05-16 03:29:14 -0400
commit481863c4e82d320128b95df9c1f07c23e077253b (patch)
tree601663c4aaa50e238dd88f319a00c5d10bcbd9d6 /MUMPS-shared-seq.patch
parent0ad378f138e32b416ca7076dd34b96a2b188c27e (diff)
downloadaur-481863c4e82d320128b95df9c1f07c23e077253b.tar.gz
Add shared compiling
Diffstat (limited to 'MUMPS-shared-seq.patch')
-rw-r--r--MUMPS-shared-seq.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/MUMPS-shared-seq.patch b/MUMPS-shared-seq.patch
new file mode 100644
index 000000000000..565da49ef688
--- /dev/null
+++ b/MUMPS-shared-seq.patch
@@ -0,0 +1,42 @@
+Create a shared version of the sequential library, MUST BE LAST IN SERIES
+
+--- libseq/Makefile
++++ libseq/Makefile
+@@ -8,7 +8,7 @@
+ include ../Makefile.inc
+
+-libmpiseq: libmpiseq$(PLAT)$(LIBEXT)
++libmpiseq: libmpiseq$(PLAT)$(LIBEXT) libmpiseq$(PLAT).so
+
+ libmpiseq$(PLAT)$(LIBEXT): mpi.o mpic.o elapse.o
+ $(AR)$@ mpi.o mpic.o elapse.o
+
+--- libseq/Makefile
++++ libseq/Makefile
+@@ -13,10 +13,13 @@
+ libmpiseq$(PLAT)$(LIBEXT): mpi.o mpic.o elapse.o
+ $(AR)$@ mpi.o mpic.o elapse.o
+ $(RANLIB) $@
++libmpiseq$(PLAT).so: mpi.o mpic.o elapse.o
++ $(FC) -shared $^ -Wl,--as-needed -Wl,-soname,libmpiseq$(PLAT).so.$(SONAME_VERSION) -o libmpiseq$(PLAT).so.$(SONAME_VERSION)
++ ln -fs libmpiseq$(PLAT).so.$(SONAME_VERSION) $@
+ .f.o:
+- $(FC) $(OPTF) -c $*.f $(OUTF)$*.o
++ $(FC) $(OPTF) -fPIC -c $*.f $(OUTF)$*.o
+ .c.o:
+- $(CC) $(OPTC) $(CDEFS) -I. -c $*.c $(OUTC)$*.o
++ $(CC) $(OPTC) $(CDEFS) -I. -fPIC -c $*.c $(OUTC)$*.o
+
+ clean:
+ $(RM) *.o *$(LIBEXT)
+
+--- Makefile 2015-02-20 19:51:32.021098000 +0100
++++ Makefile 2015-02-20 19:52:13.535854348 +0100
+@@ -57,6 +57,7 @@
+
+ libseqneeded:
+ (cd libseq; $(MAKE))
++ cp libseq/lib* $(libdir)
+
+ # Build the libpord.a library and copy it into $(topdir)/lib
+ $(libdir)/libpord$(PLAT).a: