summarylogtreecommitdiffstats
path: root/Make.user
diff options
context:
space:
mode:
authorMarco Munari2022-01-22 23:01:39 +0100
committerMarco Munari2022-01-22 23:47:05 +0100
commit7a4ab5fb68ff3812ba42e9403f17889933eb9ef7 (patch)
treed015aececbe2b29fdea4bc5863616a34c4fcd8f6 /Make.user
parent1a5991df8b4a2e9f707a7db9c5fddbce581ba9f2 (diff)
downloadaur-7a4ab5fb68ff3812ba42e9403f17889933eb9ef7.tar.gz
- Let julia build more own chosen deps:
libunwind, pcre2 and mpfr (not to use some more of the system libs, as occurred arch system versions got out of sync against julia choice) - make test instead of testall. `make test` does currently the following bit less than the preceding command in check() correspondent to `make testall` LibGit2/online Pkg the difference is given by the argument `default` or `all` to runtests.jl See diff <(make -n test) <(make -n testall) then add argument --help-list at the invocation of runtests.jl to list and compare the tests run by `default` or `all` flavor consider running some `make` command with -j1 argument in low memory machines (the minimum seems to be in the order of 12Gb+ of available memory and 20Gb of Swap) - while testing this change the failure of test for pcre2 and mpfr is just due to a version-string comparison, 'pcre2=10.36.0' current system version would be 10.39 'mpfr=4.1.0' a string version check refuses current version 4.1.0-p13 I let julia build internally such libraries too the official changes description of pcre are in https://github.com/PhilipHazel/pcre2/blob/master/ChangeLog Also the attempt to prepare the deps source files with `make full-source-dist` (now commented out) fails because since at least November 4th 2020 the used url in pcre.mk, ftp.pcre.org is "not anymore" online (as said in https://pcre.org) I opened julia development issue https://github.com/JuliaLang/julia/issues/43895 - Remove an obsolete cp Make.user, because being specified in the sources, an absolute symbolic link is created in src dir - Removed a comment mentioning USE_SYSTEM_ARPACK, not anymore used - Update dependency also with version range according to https://github.com/JuliaLang/julia/blob/master/doc/src/devdocs/build/build.md#required-build-tools-and-external-libraries if you have enough RAM there is chance that the build succeeds
Diffstat (limited to 'Make.user')
-rw-r--r--Make.user10
1 files changed, 7 insertions, 3 deletions
diff --git a/Make.user b/Make.user
index b7aeecd3b422..ceec93e42b56 100644
--- a/Make.user
+++ b/Make.user
@@ -1,16 +1,19 @@
+#See doc/src/devdocs/build/linux.md
prefix:=/usr
sysconfdir:=/etc
+#FORCE_ASSERTIONS=1
+#LLVM_ASSERTIONS=1
#MARCH=${CARCH/_/-}
USE_SYSTEM_LLVM:=0
-USE_SYSTEM_LIBUNWIND:=1
-USE_SYSTEM_PCRE:=1
+USE_SYSTEM_LIBUNWIND:=0
+USE_SYSTEM_PCRE:=0
USE_SYSTEM_LIBM:=0
USE_SYSTEM_OPENLIBM:=1
USE_SYSTEM_DSFMT:=0
USE_SYSTEM_BLAS:=0
USE_SYSTEM_LAPACK:=0
USE_SYSTEM_GMP:=0
-USE_SYSTEM_MPFR:=1
+USE_SYSTEM_MPFR:=0
USE_SYSTEM_SUITESPARSE:=0
USE_SYSTEM_LIBUV:=0
USE_SYSTEM_UTF8PROC:=1
@@ -21,3 +24,4 @@ USE_SYSTEM_LIBGIT2:=0
USE_SYSTEM_PATCHELF:=1
USE_SYSTEM_ZLIB:=1
USE_SYSTEM_P7ZIP:=1
+LDFLAGS=-Wl,-rpath,/usr/lib/