summarylogtreecommitdiffstats
path: root/Makefile-runtime.patch
diff options
context:
space:
mode:
authorXuanrui Qi2019-04-27 00:40:09 -0400
committerXuanrui Qi2019-04-27 00:40:09 -0400
commit785d620c9236ebb6ffb01ae04a6cf758b8ff721a (patch)
tree37f8c50d2f2715e823b3998ca70bf57196e1af79 /Makefile-runtime.patch
downloadaur-785d620c9236ebb6ffb01ae04a6cf758b8ff721a.tar.gz
Initial commit
Diffstat (limited to 'Makefile-runtime.patch')
-rw-r--r--Makefile-runtime.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile-runtime.patch b/Makefile-runtime.patch
new file mode 100644
index 000000000000..77aa1f4d0bbd
--- /dev/null
+++ b/Makefile-runtime.patch
@@ -0,0 +1,23 @@
+--- runtime/Makefile 2019-04-27 00:16:12.285242632 -0400
++++ runtime/Makefile.fixed 2019-04-27 00:17:03.020157520 -0400
+@@ -70,16 +70,16 @@
+
+ ifeq ($(strip $(HAS_RUNTIME_LIB)),true)
+ install::
+- install -d $(LIBDIR)
+- install -m 0644 $(LIB) $(LIBDIR)
++ install -d $(DESTDIR)/$(LIBDIR)
++ install -m 0644 $(LIB) $(DESTDIR)/$(LIBDIR)
+ else
+ install::
+ endif
+
+ ifeq ($(strip $(HAS_STANDARD_HEADERS)),true)
+ install::
+- install -d $(LIBDIR)/include
+- install -m 0644 $(INCLUDES) $(LIBDIR)/include
++ install -d $(DESTDIR)/$(LIBDIR)/include
++ install -m 0644 $(INCLUDES) $(DESTDIR)/$(LIBDIR)/include
+ else
+ install::
+ endif