summarylogtreecommitdiffstats
path: root/Makefile.Arch
diff options
context:
space:
mode:
authorJoey Dumont2017-06-26 07:02:46 -0400
committerJoey Dumont2017-06-26 07:02:46 -0400
commit52ac76d8670aaf8710afa439377dffb72bb9e01c (patch)
tree13f12e235268e62f6cc44f6d8df2eb75c28707d4 /Makefile.Arch
parentc1dd9637c51eb8836739a001a5c581c9441759c2 (diff)
downloadaur-52ac76d8670aaf8710afa439377dffb72bb9e01c.tar.gz
Updated to depend on gcc63.
Diffstat (limited to 'Makefile.Arch')
-rw-r--r--Makefile.Arch11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.Arch b/Makefile.Arch
index 9acafa41793d..d0247daf0d33 100644
--- a/Makefile.Arch
+++ b/Makefile.Arch
@@ -1,17 +1,18 @@
# Based on 'Makefile.Debian', part of pdftk
# Copyright (c) 2004-2012 Sid Steward
-export CXX= g++
-export GCJ= gcj
-export GCJH= gcjh
-export GJAR= gjar
+export CXX= g++-6.3
+export GCJ= gcj-6.3
+export GCJH= gcjh-6.3
+export GJAR= gjar-6.3
+export CC1PLUS= cc1plus-6.3
export LIBGCJ= /usr/share/java/libgcj.jar
export AR= ar
export RM= rm
export ARFLAGS= rs
export RMFLAGS= -vf
export CPPFLAGS= -DPATH_DELIM=0x2f -DASK_ABOUT_WARNINGS=false -DUNBLOCK_SIGNALS -fdollars-in-identifiers -fPIC
-export CXXFLAGS= -O2 -fPIC
+export CXXFLAGS= -O2 -fPIC -I/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include/c++/ -I/usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/include/c++/x86_64-pc-linux-gnu
export GCJFLAGS= -Wno-all -fsource=1.3 -O2 -fPIC
export GCJHFLAGS= -force
export LDLIBS= -lgcj