summarylogtreecommitdiffstats
path: root/Makefile.am.patch
diff options
context:
space:
mode:
authorKevin Brubeck Unhammer2015-07-14 10:23:29 +0200
committerKevin Brubeck Unhammer2015-07-14 10:23:29 +0200
commit26ea8282981c717a43e629853acd8e2a56e72b7d (patch)
tree2251bcc949d36161e0cdaeec3b4baded3733f5e9 /Makefile.am.patch
downloadaur-apertium-oc-ca.tar.gz
Initial import
Diffstat (limited to 'Makefile.am.patch')
-rw-r--r--Makefile.am.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/Makefile.am.patch b/Makefile.am.patch
new file mode 100644
index 000000000000..47228537706e
--- /dev/null
+++ b/Makefile.am.patch
@@ -0,0 +1,76 @@
+--- ../apertium-oc-ca-1.0.5/Makefile.am 2008-07-21 13:02:56.000000000 +0200
++++ apertium-oc-ca-1.0.5/Makefile.am 2010-09-15 16:32:22.000000000 +0200
+@@ -19,7 +19,7 @@
+ $(PREFIX2).autogen.bin $(PREFIX2b).autogen.bin \
+ $(PREFIX1).autopgen.bin $(PREFIX1b).autopgen.bin \
+ $(PREFIX2).autopgen.bin $(PREFIX2b).autopgen.bin modes
+-
++
+ TARGETS = $(TARGETS_COMMON) $(PREFIX1).t1x.bin $(PREFIX1).t2x.bin $(PREFIX1).t3x.bin \
+ $(PREFIX1b).t1x.bin $(PREFIX1b).t2x.bin $(PREFIX1b).t3x.bin \
+ $(PREFIX2).t1x.bin $(PREFIX2).t2x.bin $(PREFIX2).t3x.bin \
+@@ -72,7 +72,7 @@
+
+ .deps/$(LANG2b).post.dix: $(BASENAME).post-$(LANG2).dix
+ xsltproc --stringparam alt $(LANG1b) alt.xsl $(BASENAME).post-$(LANG2).dix >$@
+-
++
+ $(PREFIX1).automorf.bin: .deps/$(LANG1).dix
+ apertium-validate-dictionary .deps/$(LANG1).dix
+ lt-comp lr .deps/$(LANG1).dix $@
+@@ -136,7 +136,7 @@
+ $(PREFIX2b).autopgen.bin: .deps/$(LANG1b).post.dix
+ apertium-validate-dictionary .deps/$(LANG1b).post.dix
+ lt-comp lr .deps/$(LANG1b).post.dix $@
+-
++
+ $(PREFIX1).t1x: $(BASENAME).$(PREFIX1).t1x
+ xsltproc --stringparam alt $(LANG1) alt.xsl $(BASENAME).$(PREFIX1).t1x > $@
+ apertium-validate-transfer $@
+@@ -168,7 +168,7 @@
+ $(PREFIX2b).t2x: $(BASENAME).$(PREFIX2).t2x
+ xsltproc --stringparam alt $(LANG1b) alt.xsl $(BASENAME).$(PREFIX2).t2x > $@
+ apertium-validate-interchunk $@
+-
++
+ $(PREFIX1).t3x: $(BASENAME).$(PREFIX1).t3x
+ xsltproc --stringparam alt $(LANG1) alt.xsl $(BASENAME).$(PREFIX1).t3x > $@
+ apertium-validate-postchunk $@
+@@ -233,19 +233,18 @@
+ $(BASENAME).$(PREFIX1).t1x $(BASENAME).$(PREFIX2).t1x \
+ $(BASENAME).$(PREFIX1).t2x $(BASENAME).$(PREFIX2).t2x \
+ $(BASENAME).$(PREFIX1).t3x $(BASENAME).$(PREFIX2).t3x
+-
+-
++
+ modes: modes.xml Makefile.am
+ apertium-gen-modes modes.xml
+ @cp *.mode modes
+-
++
+ $(INSTALL_MODES): modes.xml Makefile.am
+ apertium-gen-modes modes.xml
+ @cp *.mode modes
+
+ apertium_oc_cadir=$(prefix)/share/apertium/apertium-$(PREFIX1)/
+ apertium_oc_camodesdir=$(prefix)/share/apertium/modes/
+-
++
+ apertium_oc_ca_DATA=$(PREFIX1).automorf.bin $(PREFIX2).automorf.bin \
+ $(PREFIX1).autobil.bin $(PREFIX2).autobil.bin \
+ $(PREFIX1).autogen.bin $(PREFIX2).autogen.bin \
+@@ -267,9 +266,9 @@
+
+ install-data-local:
+ apertium-gen-modes modes.xml apertium-$(PREFIX1)
+- $(INSTALL_DATA) oc-ca.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) ca-oc.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) oc_aran-ca.mode $(apertium_oc_camodesdir)
+- $(INSTALL_DATA) ca-oc_aran.mode $(apertium_oc_camodesdir)
+-
++ $(INSTALL_DATA) oc-ca.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) ca-oc.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) oc_aran-ca.mode $(DESTDIR)$(apertium_oc_camodesdir)
++ $(INSTALL_DATA) ca-oc_aran.mode $(DESTDIR)$(apertium_oc_camodesdir)
++
+ CLEANFILES = -r $(TARGETS)