summarylogtreecommitdiffstats
path: root/Makefile.config
diff options
context:
space:
mode:
authorDaniel Bermond2019-05-18 20:14:30 +0000
committerDaniel Bermond2019-05-18 20:14:30 +0000
commit38284ed64ba6e56880a801670a2c971afa968348 (patch)
tree38cc25fa4e010e862de44d3db8b0f1f86473d9aa /Makefile.config
parent53954ba06b361941cc971a55a9fed1fb1cd55815 (diff)
downloadaur-38284ed64ba6e56880a801670a2c971afa968348.tar.gz
Fix docs build. Update dependencies.
Diffstat (limited to 'Makefile.config')
-rw-r--r--Makefile.config7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.config b/Makefile.config
index 6e9768352630..a78432bd9c6c 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -7,15 +7,20 @@ USE_OPENCV := 1
USE_LEVELDB := 1
USE_LMDB := 1
OPENCV_VERSION := $(_OCVMAJ)
-CUSTOM_CXX := g++-7
+CUSTOM_CXX := g++
CUDA_DIR := /opt/cuda
CUDA_ARCH := -gencode arch=compute_30,code=sm_30 \
+ -gencode arch=compute_32,code=sm_32 \
-gencode arch=compute_35,code=sm_35 \
+ -gencode arch=compute_37,code=sm_37 \
-gencode arch=compute_50,code=sm_50 \
-gencode arch=compute_52,code=sm_52 \
+ -gencode arch=compute_53,code=sm_53 \
-gencode arch=compute_60,code=sm_60 \
-gencode arch=compute_61,code=sm_61 \
+ -gencode arch=compute_62,code=sm_62 \
-gencode arch=compute_70,code=sm_70 \
+ -gencode arch=compute_72,code=sm_72 \
-gencode arch=compute_75,code=sm_75 \
-gencode arch=compute_75,code=compute_75
BLAS := open