summarylogtreecommitdiffstats
path: root/Makefile.config
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-08 23:15:03 +0000
committerDaniel Bermond2018-11-08 23:15:03 +0000
commit605b9bf43344ccee8faaed68b528fde3429322e3 (patch)
treec7098598e6daf2624a53fbbdc909c6bfdd594788 /Makefile.config
parentde9fee70086a52973726b4f598d81977102ac662 (diff)
downloadaur-605b9bf43344ccee8faaed68b528fde3429322e3.tar.gz
Configure versions inside makefile. Enable tests. Use https on url.
Diffstat (limited to 'Makefile.config')
-rw-r--r--Makefile.config12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile.config b/Makefile.config
index 901d7c88b680..e82b03357ff4 100644
--- a/Makefile.config
+++ b/Makefile.config
@@ -1,8 +1,12 @@
+_PYVER := $(shell python -c 'import sys; print("%s.%s" %sys.version_info[0:2])')
+_PYMAJ := $(shell python -c 'import sys; print("%s" %sys.version_info[0])')
+_OCVMAJ := $(shell opencv_version | awk -F'.' '{ print $1 }')
+
USE_CUDNN := 1
USE_OPENCV := 1
USE_LEVELDB := 1
USE_LMDB := 1
-OPENCV_VERSION := 3
+OPENCV_VERSION := $(_OCVMAJ)
CUSTOM_CXX := g++-7
CUDA_DIR := /opt/cuda
CUDA_ARCH := -gencode arch=compute_30,code=sm_30 \
@@ -17,9 +21,9 @@ CUDA_ARCH := -gencode arch=compute_30,code=sm_30 \
BLAS := open
BLAS_INCLUDE := /usr/include
BLAS_LIB := /usr/lib
-PYTHON_LIBRARIES := boost_python3 python3.7m
-PYTHON_INCLUDE := /usr/include/python3.7m \
- /usr/lib/python3.7/site-packages/numpy/core/include
+PYTHON_LIBRARIES := boost_python$(_PYMAJ) python$(_PYVER)m
+PYTHON_INCLUDE := /usr/include/python$(_PYVER)m \
+ /usr/lib/python$(_PYVER)/site-packages/numpy/core/include
PYTHON_LIB := /usr/lib
WITH_PYTHON_LAYER := 1
INCLUDE_DIRS := $(PYTHON_INCLUDE)