summarylogtreecommitdiffstats
path: root/Makefile.config
diff options
context:
space:
mode:
authorDaniel Bermond2017-03-19 03:38:52 -0300
committerDaniel Bermond2017-03-19 03:38:52 -0300
commit148ce49ba0a5e33f4c333984f04e85583b71329c (patch)
treec401adc132ad483f43b2bb75260f241bbf3bdc07 /Makefile.config
parent9d14bfe48ff35dc7f13ae8d3f2a69f1dcacfbec7 (diff)
downloadaur-148ce49ba0a5e33f4c333984f04e85583b71329c.tar.gz
First commit after package adoption. Major rewrite.
A major rewrite was made. Most important changes: - removed 'Makefile.config' file (configuration is now made in PKGBUILD) - removed the custom 'classify.py' in order to follow upstream - removed the 250MB download during build() - removed the source tree installation in '/opt' - added cuDNN support - added NCCL support - added 'distribute' make target for easier installation - added documentation - use python3 instead of python2 note1: if you want python2 just follow PKGBUILD instructions note2: current AUR dependencies: - openblas-lapack - cudnn - nccl - python-leveldb - python-scikit-image
Diffstat (limited to 'Makefile.config')
-rw-r--r--Makefile.config78
1 files changed, 0 insertions, 78 deletions
diff --git a/Makefile.config b/Makefile.config
deleted file mode 100644
index 230d50b5f666..000000000000
--- a/Makefile.config
+++ /dev/null
@@ -1,78 +0,0 @@
-## Refer to http://caffe.berkeleyvision.org/installation.html
-# Contributions simplifying and improving our build system are welcome!
-
-# cuDNN acceleration switch (uncomment to build with cuDNN).
-# USE_CUDNN := 1
-
-# CPU-only switch (uncomment to build without GPU support).
-# CPU_ONLY := 1
-
-# To customize your choice of compiler, uncomment and set the following.
-# N.B. the default for Linux is g++ and the default for OSX is clang++
-# CUSTOM_CXX := g++
-
-# CUDA directory contains bin/ and lib/ directories that we need.
-CUDA_DIR := /opt/cuda
-# On Ubuntu 14.04, if cuda tools are installed via
-# "sudo apt-get install nvidia-cuda-toolkit" then use this instead:
-# CUDA_DIR := /usr
-
-# CUDA architecture setting: going with all of them.
-# For CUDA < 6.0, comment the *_50 lines for compatibility.
-CUDA_ARCH := -gencode arch=compute_20,code=sm_20 \
- -gencode arch=compute_20,code=sm_21 \
- -gencode arch=compute_30,code=sm_30 \
- -gencode arch=compute_35,code=sm_35 \
- -gencode arch=compute_50,code=sm_50 \
- -gencode arch=compute_50,code=compute_50
-
-# BLAS choice:
-# atlas for ATLAS (default)
-# mkl for MKL
-# open for OpenBlas
-BLAS := open
-# Custom (MKL/ATLAS/OpenBLAS) include and lib directories.
-# Leave commented to accept the defaults for your choice of BLAS
-# (which should work)!
-# BLAS_INCLUDE := /path/to/your/blas
-# BLAS_LIB := /path/to/your/blas
-
-# This is required only if you will compile the matlab interface.
-# MATLAB directory should contain the mex binary in /bin.
-# MATLAB_DIR := /usr/local
-# MATLAB_DIR := /Applications/MATLAB_R2012b.app
-
-# NOTE: this is required only if you will compile the python interface.
-# We need to be able to find Python.h and numpy/arrayobject.h.
-PYTHON_INCLUDE := /usr/include/python2.7 \
- /usr/lib/python2.7/site-packages/numpy/core/include
-# Anaconda Python distribution is quite popular. Include path:
-# PYTHON_INCLUDE := $(HOME)/anaconda/include \
- # $(HOME)/anaconda/include/python2.7 \
- # $(HOME)/anaconda/lib/python2.7/site-packages/numpy/core/include
-
-# We need to be able to find libpythonX.X.so or .dylib.
-PYTHON_LIB := /usr/lib
-# PYTHON_LIB := $(HOME)/anaconda/lib
-
-# Uncomment to support layers written in Python (will link against Python libs)
-WITH_PYTHON_LAYER := 1
-
-# Whatever else you find you need goes here.
-INCLUDE_DIRS := $(PYTHON_INCLUDE) /usr/include
-LIBRARY_DIRS := $(PYTHON_LIB) /usr/lib
-
-BUILD_DIR := build
-DISTRIBUTE_DIR := distribute
-
-# Uncomment for debugging. Does not work on OSX due to https://github.com/BVLC/caffe/issues/171
-# DEBUG := 1
-
-# The ID of the GPU that 'make runtest' will use to run unit tests.
-TEST_GPUID := 0
-
-# enable pretty build (comment to see full commands)
-Q ?= @
-
-# Indicate that OpenCV 3 is being used
-OPENCV_VERSION := 3