summarylogtreecommitdiffstats
path: root/Makefile.inc
diff options
context:
space:
mode:
authorMartin Diehl2021-04-22 07:30:00 +0200
committerMartin Diehl2021-04-22 07:30:00 +0200
commit55b36a78c25bea75692c79d71c5e2bcd4f99bc7b (patch)
tree2b64cc5ed69d46061702043d911d2f2a813605a6 /Makefile.inc
parent73b3423ea4465a07f6558b7bd128db13cf015a6a (diff)
downloadaur-55b36a78c25bea75692c79d71c5e2bcd4f99bc7b.tar.gz
build shared libraries
thanks to eDgar for the fixes
Diffstat (limited to 'Makefile.inc')
-rw-r--r--Makefile.inc12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.inc b/Makefile.inc
index 7cd8c3b3a50e..57735b552a44 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -91,7 +91,7 @@ IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
PLAT =
# Library extension, + C and Fortran "-o" option
# may be different under Windows
-LIBEXT = .a
+LIBEXT = .so
OUTC = -o
OUTF = -o
# RM : remove files
@@ -104,11 +104,11 @@ FC = mpif90
FL = mpif90
# AR : Archive object in a library
# keep a space at the end if options have to be separated from lib name
-AR = ar vr
+AR = $(CC) -shared $(OPTC) -o
# RANLIB : generate index of an archive file
# (optionnal use "RANLIB = echo" in case of problem)
-RANLIB = ranlib
-#RANLIB = echo
+# RANLIB = ranlib
+RANLIB = echo
# DEFINE HERE YOUR LAPACK LIBRARY
@@ -159,10 +159,10 @@ OPTL = ${CFLAGS} -fPIC
#Sequential:
#INCS = $(INCSEQ)
#LIBS = $(LIBSEQ)
-LIBSEQNEEDED = libseqneeded
+#LIBSEQNEEDED = libseqneeded
#Parallel:
INCS = $(INCPAR)
LIBS = $(LIBPAR)
-#LIBSEQNEEDED =
+LIBSEQNEEDED =