summarylogtreecommitdiffstats
path: root/Makefile.inc
diff options
context:
space:
mode:
authorheavysink2020-05-16 03:29:14 -0400
committerheavysink2020-05-16 03:29:14 -0400
commit481863c4e82d320128b95df9c1f07c23e077253b (patch)
tree601663c4aaa50e238dd88f319a00c5d10bcbd9d6 /Makefile.inc
parent0ad378f138e32b416ca7076dd34b96a2b188c27e (diff)
downloadaur-481863c4e82d320128b95df9c1f07c23e077253b.tar.gz
Add shared compiling
Diffstat (limited to 'Makefile.inc')
-rw-r--r--Makefile.inc9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.inc b/Makefile.inc
index 421e4fe84be3..e7db5be514a9 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -16,6 +16,7 @@
# Metis/ParMetis and SCOTCH/PT-SCOTCH (ver 6.0 and later) orderings are now available for MUMPS.
#
+SONAME_VERSION=5.3
SCOTCHDIR = /usr
ISCOTCH = -I$(SCOTCHDIR)/include/scotch
# You have to choose one among the following two lines depending on
@@ -67,7 +68,7 @@ IORDERINGSC = $(IMETIS) $(IPORD) $(ISCOTCH)
PLAT =
# Library extension, + C and Fortran "-o" option
# may be different under Windows
-LIBEXT = .a
+LIBEXT = .so
OUTC = -o
OUTF = -o
# RM : remove files
@@ -87,13 +88,15 @@ RANLIB = ranlib
#RANLIB = echo
# SCALAP should define the SCALAPACK and BLACS libraries.
-SCALAP = -lscalapack -llapack
+SCALAP = -lscalapack -llapack -lblas
# INCLUDE DIRECTORY FOR MPI
INCPAR = -I/usr/include/openmpi
# LIBRARIES USED BY THE PARALLEL VERSION OF MUMPS: $(SCALAP) and MPI
-LIBPAR = $(SCALAP) -L/usr/lib/openmpi -lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi
+MPIFLIB = -L/usr/lib/openmpi -Wl,-rpath -Wl,/usr/lib/openmpi -Wl,--enable-new-dtags -lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -lmpi
+MPICLIB = -L/usr/lib/openmpi -Wl,-rpath -Wl,/usr/lib/openmpi -Wl,--enable-new-dtags -lmpi
+LIBPAR = $(SCALAP) $(MPIFLIB)
# The parallel version is not concerned by the next two lines.
# They are related to the sequential library provided by MUMPS,