summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
authorTimothy Brown2019-01-01 03:09:46 +0000
committerTimothy Brown2019-01-01 03:09:46 +0000
commit901dd9ba1b66546b976b1c9a7bc6f4b894774620 (patch)
treeea103544b29a90ac707ad8c1017e4256c53224db /Makefile.patch
parent36cf63d2d73210e58c0c70185e70dee948c17a7a (diff)
downloadaur-901dd9ba1b66546b976b1c9a7bc6f4b894774620.tar.gz
Added patch to fix makefile install permissions.
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..7bd2a178b232
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,13 @@
+diff -ruN adjtimex-debian-1.29-10.old/Makefile.in adjtimex-debian-1.29-10/Makefile.in
+--- adjtimex-debian-1.29-10.old/Makefile.in 2018-07-25 17:02:11.000000000 +0000
++++ adjtimex-debian-1.29-10/Makefile.in 2019-01-01 02:58:05.867107891 +0000
+@@ -42,7 +42,8 @@
+ $(CC) $(CFLAGS) -c mat.c
+
+ install: all
+- $(INSTALL) -g bin -m 755 -o root adjtimex $(bindir)/adjtimex
++ $(INSTALL) -d -g root -m 755 -o root $(bindir)
++ $(INSTALL) -g root -m 755 -o root adjtimex $(bindir)/adjtimex
+ $(INSTALL) -d -g root -m 755 -o root $(mandir)
+ -$(INSTALL) -g root -m 644 -o root $(srcdir)/adjtimex.8 \
+ $(mandir)/adjtimex.$(manext)