summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
authorLuis Martinez2022-01-23 12:33:48 -0600
committerLuis Martinez2022-01-23 12:33:48 -0600
commit307b2cb81c25d0635da9b3c003e26afa2df2a03f (patch)
tree92bf5cd2b2c47bac4b9be7bfa9307787ad4a3ec9 /Makefile.patch
parent71b4c86180249e4719c352c73a2e020ab81073af (diff)
downloadaur-307b2cb81c25d0635da9b3c003e26afa2df2a03f.tar.gz
use configure for building
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..824dcaa13be6
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index fc76416..f8a2762 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,7 +13,7 @@ MANDIR=$(PREFIX)/share/man
+ VPATH=doc
+ RM=rm
+ GO=go
+-GOFLAGS=
++GOFLAGS?=
+
+ DOCS = \
+ astronaut.1
+@@ -28,7 +28,9 @@ doc: $(DOCS)
+ astronaut: $(GOSRC)
+ $(GO) build $(GOFLAGS) \
+ -ldflags "-X main.Version=$(VERSION) \
+- -X main.ShareDir=$(SHAREDIR)" \
++ -X main.ShareDir=$(SHAREDIR) \
++ -linkmode=external \
++ -extldflags=$(LDFLAGS)" \
+ -o $@
+
+ clean: