summarylogtreecommitdiffstats
path: root/Makefile.patch
diff options
context:
space:
mode:
authorhaawda2018-10-04 16:56:07 +0200
committerhaawda2018-10-04 16:56:07 +0200
commit12fcc7080a2505f3ead83608357c53bd332fae88 (patch)
tree356ed8505f475193676e42650e99f566d56a98f4 /Makefile.patch
downloadaur-12fcc7080a2505f3ead83608357c53bd332fae88.tar.gz
initial upload
Diffstat (limited to 'Makefile.patch')
-rw-r--r--Makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..61f8269ab0fa
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,27 @@
+diff -Naur nim-mode-0.4.1.orig/Makefile nim-mode-0.4.1.new/Makefile
+--- nim-mode-0.4.1.orig/Makefile 2018-10-03 23:47:34.466464558 +0200
++++ nim-mode-0.4.1.new/Makefile 2018-10-04 11:41:31.126154170 +0200
+@@ -3,20 +3,19 @@
+
+ cask_dir_exists := $(shell find ./ -type d -name ".cask")
+
+-all: test
++all: compile unit
+
+ test: clean-elc
+ $(if $(cask_dir_exists), $(skip), ${MAKE} install-dependencies)
+ ${MAKE} unit
+ ${MAKE} compile
+ ${MAKE} unit
+- ${MAKE} clean-elc
+
+ compile:
+- ${CASK} exec ${EMACS} -Q -batch -L . -f batch-byte-compile *.el
++ ${EMACS} -Q -batch -L /usr/share/emacs/site-lisp/flycheck -L /usr/share/emacs/site-lisp/ -L /usr/share/emacs/site-lisp/epc -L . -f batch-byte-compile *.el
+
+ unit:
+- ${CASK} exec buttercup -L .
++
+
+ install-dependencies:
+ ${CASK} install