summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGabriel B. Sant'Anna2020-06-23 21:14:21 -0300
committerGabriel B. Sant'Anna2020-06-23 21:14:21 -0300
commitc2b6efc878bc1701c9bdad45b623c2f28306236a (patch)
tree4cdd31b1269af97dd8a8c8bf5bcbe06b6599a77a /Makefile
parent372eec167b874e35475f24a0c27b514777f43485 (diff)
downloadaur-c2b6efc878bc1701c9bdad45b623c2f28306236a.tar.gz
Disable stripping
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index dce79dc2450e..1d3bbead5fed 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,8 @@
-PACKAGE=akku-*-any.pkg.tar.xz
-
+.PHONY: all clean verify force-build update-checksums
-default:
- @make all
+PACKAGE=akku-*-any.pkg.tar.xz
+# default
all: $(PACKAGE)
@make verify
@make .SRCINFO
@@ -13,13 +12,11 @@ clean:
-rm -R src/
-rm -R pkg/
-
# NOTE: excludes are only used to prevent namcap false positives over Guile object (.go) files
verify: PKGBUILD $(PACKAGE)
@namcap PKGBUILD
@namcap --exclude=anyelf,elfgnurelro,elfunstripped,elfnopie $(PACKAGE)
-
# forces a full makepkg build
force-build:
@LC_ALL=C makepkg -f --clean
@@ -29,7 +26,6 @@ update-checksums:
makepkg --verifysource --skipchecksums -f --nobuild --noextract
updpkgsums
-
.SRCINFO: PKGBUILD
@makepkg --printsrcinfo > .SRCINFO